View & accessibility
Thumbnails
Motion
Bforartists
5.1
Editors

EEVEE

There are three different render engines available. Workbench, EEVEE, and Cycles. This chapter has a focus on the EEVEE render engine.

8
 min read
Up to date for 
5.1
draft

Render Tab

Render Tab

There are three different render engines available. Workbench, EEVEE, and Cycles. This chapter has a focus on the EEVEE render engine.

Sampling panel

Sampling panel

Viewport subtab

EntryWhat it does
SamplesThe number of samples when rendering in the viewport.
Temporal ProjectionDenoise image using a method called temporal reprojection. This method can leave some ghosting.
Jittered ShadowsEnables jittered soft shadows in the viewport, improving shadow realism by introducing subtle randomness to shadow sampling. This helps reduce banding and aliasing artifacts in dynamic lighting setups. Note: Jittered shadows are always enabled for final renders. This is an viewport override for performance.

Render subtab

Render subtab

Samples

The number of samples when rendering to file.

Shadows subtab

Shadows subtab
EntryWhat it does
RaysThe number of samples when rendering to file.
StepsAmount of shadow ray sample per shadow ray.
Volume ShadowsGenerate shadows from volumetric material. This is very resources hungry. · Steps: Number of samples to compute volumetric shadowing.
ResolutionThe resolution scale of the shadow map.

Advanced subtab

Advanced subtab

Light Threshold

Minimum light intensity for a light to contribute to the lighting.

Clamping panel

Clamping panel

In this panel you can clamp the light values to minimum and maximum values.

EntryWhat it does
Surface subtabDirect Light: The maximum value for lights contribution on a surface. A value of zero disables this feature. Higher values will be scaled down to avoid too much noise and slow convergence at the cost of accuracy. Used by light objects. · Indirect Light: The maximum value for indirect lighting on a surface. A value of zero disables this feature. Higher values will be scaled down to avoid too much noise and slow convergence at the cost of accuracy. Used by ray-tracing and light-probes.
Volume subtabDirect Light: The maximum value for lights contribution in volumes. A value of zero disables this feature. Higher values will be scaled down to avoid too much noise and slow convergence at the cost of accuracy. Used by light objects. · Indirect Light: The maximum value for indirect lighting in volumes. A value of zero disables this feature. Higher values will be scaled down to avoid too much noise and slow convergence at the cost of accuracy. Used by light-probes.

Raytracing panel

Raytracing panel

Use Ray-Tracing

Use ray-tracing.

Presets

Presets

Allows you to store raytracing presets. To add a new preset type in a new preset name into the edit box at the end of the list, and click at the + sign.

To remove a preset click at the - sign behind the name.

Method

Method

Select the tracing method to find scene-ray intersections.

EntryWhat it does
Light ProbeRaytracing using light probes.
Screen-TraceRaytracing against the depth buffer.

Resolution

Resolution

The ray-tracing resolution. 1 Ray per pixel, 1 ray per 4 pixel, 1 ray per 16 pixel.

Screen tracing subpanel

Screen tracing subpanel

Just visible with the method Screen-Trace

EntryWhat it does
PrecisionPrecision of screen space ray-tracing.
ThicknessSurface Thickness used to detect intersection when using screen-tracing.

Denoising Subpanel

Denoising Subpanel
EntryWhat it does
DenoisingEnable Denoising for raytraced effects.
Spatial ReuseReuse the rays of neighbour pixe.
Temporal AccumulationAccumulate samples by reprojecting last tracing results
Bilateral FilterBlur the resolved radiance by reprojecting last tracing result of the temporal accumulation.

Fast GI Approximation subpanel

Fast GI Approximation subpanel
Fast GI Approximation subpanel
Threshold

Maximum roughness to use the tracing pipeline for. Higher roughness surfaces will use Fast GI Approximation. A value of 1 will disable Fast GI Approximation.

Method
Method
EntryWhat it does
Ambient occlusionUses Ambient occlusion instead of Global Illumination. Ambient Occlusion is self shadowing, and doesn't calculate colors.
Global IlluminationComputes global illumination. It takes light bounces off surrounding objects into account.
Resolution
Resolution

The resolution of the AO or GI map. It is relative to the render resolution. 1 is the size of the full render resolution, 1/2 is half the size of render resolution, and so on.

EntryWhat it does
RaysAmount of GI or AO rays to trace for each pixel.
StepsAmount of screen sample per GI or AO ray.
PrecisionPrecision of the Fast GI ray matching.
DistanceIf non zero, the maximum distance at which other surfaces will contribute to the Fast GI approximation.
Thickness near / farGeometric thickness of the surfaces when computing GI or AO. This feature reduces light leaking and missing contact occlusion.
BiasBias the shading normal to reduce self intersection artifacts.

Volumes panel

Volumes panel

Contains volumetrics settings.

EntryWhat it does
ResolutionThe resolution of the Volumes map. It is relative to the render resolution. 1 is the size of the full render resolution, 1/2 is half the size of render resolution, and so on.
StepsNumber of samples to compute for the volumetrics effect.
DistributionDistribute more samples closer to the camera.
Max DepthMaximum surface intersection count used by the accurate volume intersection method. Thise feature will create artifacts if it is exceeded.

Custom Range subpanel

Custom Range subpanel

Enable custom start and end distances for volume computation.

Start / End

The start and end values for computation.

Curves panel

Shape

Shape

Choose if the hair is displayed as strand or as strip.

Additional Subdiv

Additional subdivision along the hair.

Simplify panel

Simplify panel

Sometimes you want to simplify the rendering without to loose the already tweaked settings and adjustments. For test renderings for example. Simplify allows you to simplify the rendering.

EntryWhat it does
EnableIn the header is a checkbox to enable Simplify.
Viewport subpanelThis section affects the rendering with Eevee in the Viewport. · Max Subdivisions: Limit the number of maximum subdivisions. · Max Child Particles: Limit the number of child particles. · Volume Resolution: Simplify volumes by setting the resolution percentage of volume objects in viewport. · Normals: Skip computing custom normals and face corner normals for displaying meshes in the viewport.

Render

Render

This section affects the rendering with Eevee to file.

EntryWhat it does
Max SubdivisionsLimit the number of maximum subdivisions.
Max Child ParticlesLimit the number of child particles.

Grease Pencil

Grease Pencil

This section affects Grease Pencil drawings.

EntryWhat it does
EnableEnables the Grease Pencil features.
Playback OnlySimplify Grease Pencil only during animation playback.
FillDisplay Fill strokes in the Viewport.
ModifiersApply modifiers in the viewport.
Shader Effectsdisplay shader effects.
Layers TintingDisplay layers tint.
AntialiasingUse antialiasing to smooth stroke edges.

Depth of Field panel

Depth of Field panel
Depth of Field panel
EntryWhat it does
Max SizeThe maximum size of the bokeh shape for Depth of Field. Lower is faster.
Sprite ThresholdBrightness threshold for using sprite base depth of field.
Neighbor RejectionThe maximum brightness to consider when rejecting bokeh sprites based on neighborhood. Lower is faster.

Jitter Camera

Jitter Camera

Jitter the camera to create accurate blurring by using render samples.

Overblur

Apply blur to each jittered sample to reduce undersampling artifacts.

Motion Blur panel

Motion Blur panel

Enable Motion Blur and adjust the settings.

Each object has also its own settings to control motion blur. These options can be found in the corresponding Object tab of the Properties editor.

Enable

In the header is a checkbox to enable Simplify.

Position

Position

Controls at what point the shutter opens in relation to the frame.

EntryWhat it does
ShutterTime taken in frames between shutter open and close.
Bleeding BiasReduce background bleeding onto foreground elements. Lower values = less bleeding.
Max BlurThe maximum blur distance that a pixel can spread over.
StepsControls the accuracy of motion blur. More steps means longer render time.

Shutter Curve

Shutter Curve

Sutter curve is a sub menu wAdjust a curve for the shutter effect.

Navigation elements

The navigation elements at the top are described from left to right.

Zoom in and out

The two buttons with the magnifying glass at it zooms in and out in the curve window.

Clipping
Clipping

Clipping options. Set up clipping for the stroke.

Tools
Tools

Tools is a menu that contains some curve related tools.

EntryWhat it does
Reset ViewResets the curve windows zoom.
Extend HorizontalCauses the curve to stay horizontal before the first point and after the last point.
Extend ExtrapolatedCauses the curve to extrapolate before the first point and after the last point, based on the shape of the curve.
Reset CurveResets the curve to the initial shape.

Handles

Handles
EntryWhat it does
Vector HandleSet handle type to Vector.
Auto HandleSet handle type to Auto.
Auto Clamped HandleSet handle type to Auto Clamped.
X and Y valuesThe coordinates of the currently selected curve point.

Presets

Presets

Curve presets.

Delete Points

Deletes selected curve points.

Film panel

Film panel

Filter Size

The width over which the reconstruction filter combines samples.

Animate Property

This property can be animated. Activating this button sets a keyframe.

Overscan

Overscan

Internally render past the image borders to avoid screen space effects disappearing.

Overscan Size

How much bigger the image should be internally rendered.

Performance panel

Performance panel

High Quality Normals

Use high quality tangent space. Slower but more accurate.

Memory Subpanel

Memory Subpanel

Shadow Pool

Shadow Pool

How much shadow data can be allocated for the scene. More ram usage means more possible shadows. This affects the GPU ram usage.

Light Probes Volume Pool

Light Probes Volume Pool
Light Probes Volume Pool

How much Light probes Volume data can be allocated for the scene. More ram usage means more possible light probes volumes. This affects the GPU ram usage.

Viewport Subpanel

Viewport Subpanel

Pixel Size

Pixel Size

The pixel size for viewport rendering.

Automatic depends of the user interface scale. 1 renders at full resolution. 8 renders just in 12.5% of the size.

Compositor Subpanel

Compositor Subpanel

Realtime compositor settings.

Device

Which device to use for realtime compositing.

Precision

Precision

Precision menu just appears with GPU device selected.

EntryWhat it does
AutoFull precision at rendering, half precision otherwise.
FullFull precision in all cases.
Denoise nodes subpanel
Denoising device

The device for the denoise nodes in the compositor.

Preview quality
Preview quality

The quality for preview.

Final quality
Final quality

The quality for the final.