View & accessibility
Thumbnails
Motion
Bforartists
5.1
Editors

Tool Tab - Mesh - Texture Paint Mode

The Texture Paint Mode provides you the tools to paint directly at the texture of your mesh in the viewport. To fix visible seams for example.

30
 min read
Up to date for 
5.1
draft

Tools Tab in Texture Paint Mode

Tools Tab in Texture Paint Mode
Tools Tab in Texture Paint Mode

The Texture Paint Mode provides you the tools to paint directly at the texture of your mesh in the viewport. To fix visible seams for example.

The Texture Paint mode is just available for mesh objects.

Requirements

Requirements

Texture Painting requires to have a working UV mapping and a texture applied. When there is no UV mapping and no assigned texture, then you will get a warning about No Texture. You have to create a texture slot first.

Open the Texture Paint Slot drop down menu, and choose Base Color. This will call a menu. Create a new blank texture.

Save Texture

The result of texture painting can be found and be saved in the UV Image Editor. You can also paint in the UV editor.

The modified texture does NOT save with the scene. You have to save out the image when you want to save the changes at the texture. There is no warning. So DON'T FORGET TO SAVE THE TEXTURE.

Save Texture

Brush Asset Panel

Brush Asset Panel

The Brush Asset Panel contains the different Brushes and some Brush settings. Choose and adjust your current active brush.

Browse Brush

The big image at the top is a dropdown box that allows you to choose a brush. Click at it, and you will see the different brushes. A click at one of the images will choose this brush then.

Browse Brush

Brushes are assets. You can load them from different libraries if you want.

Brush Specials menu

Brush Specials menu

This menu becomes active when you create a new brush. Which can be done wiht the Plus button in the name property. This data cannot be changed for builtin system brushes.

Edit Metadata

Edit Metadata

Calls a popup where you can adjust further informations and settings for the brush.

EntryWhat it does
CatalogThe asset catalog in which the brush is stored.
AuthorThe brush author.
DesctriptionAdd a description
OK / CancelAccept or decline the changes.
Edit Preview ImageAllows you to load a custom preview image.
EntryWhat it does
Save Brush AssetThis button is just active with a custom brush. It saves all changes made at the brush settings into the current custom brush.
Revert Brush AssetReverts the brush settings to the default values of the brush in the asset library.

Name

Name

The edit box below the Image shows the name of the current active brush.

The + button allows you to add a new pencil with the current settings. Note that the brushes are NOT automatically saved when you close Bforartists. You need to save the brush asset. See above.

The X button deletes the brush from the brushes list and from the asset library. This button is just active with a custom brush. You will be prompted by a warning so that you don't accidentally remove the brush.

Name

Brush settings Panel

Brush Panel

Brush Panel

The Brush Panel contains the different paint brushes, a color dialog, and some brush settings.

Blend

Blend

Define how the stroke will blend. You can choose between various blend modes.

Radius

The Radius edit box allows you to adjust the radius of the brush. The button behind the edit box enables tablet pressure sensitivity for radius.

Size Pressure

The first button behind the edit box enables tablet pressure sensitivity for radius.

Pressure Size Curve

Pressure Size Curve

Behind the pressure size button there is a button to reveal the size pressure curve panel. When you activate Size Pressure for tablets, then the Size Pressure curve becomes active, and can be adjusted.

The pressure size curve allows you to adjust the falloff curve for the tablet pressure. It shows when Use Pressure is activated. The curve panel shows when clicking at the button.

Selecting Points
Selecting Points

You can select curve points. This reveals two edit boxes for the x and y coordinate of this point.

Selected points can be moved around. Left click at them, hold the mouse button down and move them to a new location.

Adding Points
Adding Points

You can add new curve points by simply left clicking at the curve. Move the mouse to position them where you need it.

Navigation elements
EntryWhat it does
Zoom inZooms in.
Zoom outZooms out.
Clipping options
Clipping options

Set up clipping for the stroke.

Tools
Tools

Tools is a menu where you can find some curve related tools.

EntryWhat it does
Reset ViewResets the curve windows zoom.
Reset CurveResets the curve to the initial shape.
Handles
Handles

You can choose between Auto handle, Vector Handle and Auto Clamped.

Position X / Y

The position of the selectedc curve point.

Delete Points

Deletes the selected curve point.

Curve Presets
Curve Presets

A curve preset to start with.

Use Unified Radius

The second button behind the edit box enables global radius size. Any modification at the radius will also modify the radius value for other paint tools.

Strength

The Strength edit box allows you to adjust the strength of the brush. The button behind the edit box enables tablet pressure sensitivity for strength.

Size Pressure

The first button behind the edit box enables tablet pressure sensitivity for radius.

Pressure Size Curve

Pressure Size Curve

Behind the pressure size button there is a button to reveal the size pressure curve panel. When you activate Size Pressure for tablets, then the Size Pressure curve becomes active, and can be adjusted.

The pressure size curve allows you to adjust the falloff curve for the tablet pressure. It shows when Use Pressure is activated. The curve panel shows when clicking at the button.

Selecting Points
Selecting Points

You can select curve points. This reveals two edit boxes for the x and y coordinate of this point.

Selected points can be moved around. Left click at them, hold the mouse button down and move them to a new location.

Adding Points
Adding Points

You can add new curve points by simply left clicking at the curve. Move the mouse to position them where you need it.

Navigation elements
EntryWhat it does
Zoom inZooms in.
Zoom outZooms out.
Clipping options
Clipping options

Set up clipping for the stroke.

Tools
Tools

Tools is a menu where you can find some curve related tools.

EntryWhat it does
Reset ViewResets the curve windows zoom.
Reset CurveResets the curve to the initial shape.
Handles
Handles

You can choose between Auto handle, Vector Handle and Auto Clamped.

Position X / Y

The position of the selectedc curve point.

Delete Points

Deletes the selected curve point.

Curve Presets
Curve Presets

A curve preset to start with.

Use Unified Radius

The second button behind the edit box enables global radius size. Any modification at the radius will also modify the radius value for other paint tools.

Brush Settings Panel - Color Picker Sub panel

Brush Settings Panel - Color Picker Sub panel
Brush Settings Panel - Color Picker Sub panel

Define the color for your brush.

The active color is the left one. When you click the button with the two arrows down right then you can swap the color with the secondary color. Then this secondary color becomes the primary color, and is active.

Brush Settings Panel - Color Picker Sub panel
Brush Settings Panel - Color Picker Sub panel

A click at one of the color fields will open a more detailed color dialog, where you can set up the color by using rgb, hsv and hex colors and with value sliders.

EntryWhat it does
Brush colors flipFlips the primary color with the secondary color.
Use unified ColorChoose if you want to use global colors or local color just for vertex painting.

Brush Settings Panel - Color Palette Sub panel

Brush Settings Panel - Color Palette Sub panel
Brush Settings Panel - Color Palette Sub panel

Create a color palette for later reuse.

Brush Settings Panel - Color Palette Sub panel
Brush Settings Panel - Color Palette Sub panel

First create a new palette by clicking at New. Then adjust the color in the color picker. And then click at the add button to add this color to the palette.

To set the color picker to a palette color simply click at this palette color.

To remove a color from the palette, choose it, then click at the remove button. The active palette color that gets removed is the one with the triangle at it.

The color palette cannot be saved externally. It is part of the current blend file. You can however append color palettes from other blend files.

The elements are explained from left to right.

Palette browser

Palette browser

The button at the left opens a dropdown list where you can choose between your palettes.

EntryWhat it does
Edit BoxThe name of the currently active palette. You can also rename the palette here. A click into the edit box makes the name editable.
Number of usersSee how many users the palette currently has.
Fake UserFake User sets the element to have a fake user. Zero user data-blocks are normally not saved. But sometimes you want to force the data to be kept even when the data block has no user.
Add paletteAdd a new palette.
Remove PaletteClicking at this button removes the palette. Note that you need to save, close Bforartists and reload the blend file to remove the palette completely.

Sort By

Sort By

Sort the palette by the chosen method.

Brush Settings Panel - Advanced Subpanel

Brush Settings Panel - Advanced Subpanel
Brush Settings Panel - Advanced Subpanel

Brush specific settings.

EntryWhat it does
Brush TypeDisplays the current brush type (e.g., **Draw, **Blur, Average, Smear)
AccumulateAccumulate stroke daubts on top of each other.
Affect AlphaWhen disabled then the alpha is locked while painting.

Randomize Color – Subpanel

Randomize Color – Subpanel
Randomize Color – Subpanel

Adds variation to the brush color per stroke or while drawing a stroke.

EntryWhat it does
Slider PropertiesStroke Randomization: Use randomness per stroke, instead of while drawing a stroke. This will define a new random value when you draw a new stroke. · Use Pressure: Uses the brush pressure to define how random the influence will be. Maximum pressure is maximum randomization.
HueShifts the base color across the color wheel.
SaturationAdjusts the intensity of the color.
ValueModifies the brightness of the stroke.

Modes – Subpanel

Modes – Subpanel

Allows to expose the brush in different modes sharing common attributes.

Example: You can make a brush for vertex mode and also texture paint mode.

Sharpen / Soften (Soften Brush)

Sharpen / Soften (Soften Brush)
Sharpen / Soften (Soften Brush)

Sharp Threshold

The threshold below which no sharpening is performed.

Blur Mode (Soften Brush)

Choose the blur method. Gaussian or Box.

Mask Value (Mask brush)

Mask Value (Mask brush)
Mask Value (Mask brush)

The vertex weight when brush is applied.

Brush specific settings.

Brush Settings Panel - Texture Subpanel

Brush Settings Panel - Texture Subpanel
Brush Settings Panel - Texture Subpanel

The Texture panel allows you to paint with textures. This allows you for example to grab a foto from some fish scales, and simply paint them onto the vertices by using this image as a pencil. Or as a blueprint where you calk through ( Stencil method ).

Browse Texture to be linked

Browse Texture to be linked
Browse Texture to be linked

The image at the top of the panel is a image browser. Choose a texture that you can choose for vertex painting then. You can also have more than one image loaded at once.

Browse Texture to be linked
Browse Texture to be linked

In this shot there is already a texture added. The way to add the texture here is a bit more complicated. And not done with clicking at the New button.

First click at the New button below the image. This will create a new texture slot. This slot is still empty, it displays black.

We need to load the texture in this slot. This must be done in the Properties editor in the Textures tab. And then the texture finally shows in the Texture panel in the Tool Shelf.

The problem is, we have an object with a material and a texture already selected. And when we change this texture , then we don't get the pencil texture loaded. But we change the texture at our mesh.

What we need to do is to create a material first. And in this material we load our pencil texture then. And then this texture becomes available in the image browser of the Texture panel.

Browse Texture to be linked
Browse Texture to be linked
Browse Texture to be linked
Browse Texture to be linked
Browse Texture to be linked
Browse Texture to be linked
Browse Texture to be linked
Browse Texture to be linked
Browse Texture to be linked
Browse Texture to be linked

And when we switch back to the tools tab, then the texture is loaded. And we can work with this texture.

Texture Edit box

Texture Edit box

The Texture edit box is the edit box below the Image browser. When there's no image loaded then it displays the New button. When there's a image (or more) loaded, then you will see the name of the current texture.

The F button turns this texture into a data block with a fake user. Means it will exists even when there is no data connected to it anymore.

When you activate Fake User, then you may get a value in front of it, which displays how much users this data block (our texture slot) currently has.

The + Button adds another texture slot. Note that you will have to load a texture too, as explained above.

The X button deletes the texture slot.

Brush Mapping

Brush Mapping

Our texture can be mapped in different methods. The Brush mapping is a dropdown box where you can choose this different brush mapping methods.

The settings vary. So we will go through them by the different brush mapping methods.

Brush Mapping with mapping method Tiled

Brush Mapping with mapping method Tiled
Brush Mapping with mapping method Tiled

The brush mapping method Tiled tiles the brush stroke at the surface. The mapping happens from the current view. The result may be distorted when the view does not align with the surface of the object.

Angle

Angle

The angle of the brush.

EntryWhat it does
OffsetThe offset of the texture in the brush.
SizeThe size of the texture in the brush.

Brush Mapping with mapping method View Plane

Brush Mapping with mapping method View Plane
Brush Mapping with mapping method View Plane

The brush mapping method View Plane simply paints onto the surface. The mapping happens from the current view. The result may be distorted when the view does not align with the surface of the object.

EntryWhat it does
AngleThe angle of the brush. · Rake: The angle follows the direction of the brush stroke. · Random: The brush angle gets set random.
OffsetThe offset of the texture in the brush.
SizeThe size of the texture in the brush.

Brush Mapping with mapping method 3D

Brush Mapping with mapping method 3D
Brush Mapping with mapping method 3D

The brush mapping method 3D paints the texture at the surface, by tiling it 1/1 at the object surface.

Offset

Offset

The offset of the texture in the brush.

Size

The size of the texture in the brush.

Brush Mapping with mapping method Random

Brush Mapping with mapping method Random
Brush Mapping with mapping method Random

The brush mapping method Random paints onto the surface, and randomizes the texture position in the brush while that. The mapping happens from the current view. The result may be distorted when the view does not align with the surface of the object.

Angle

Angle

The angle of the brush.

EntryWhat it does
RakeThe angle follows the direction of the brush stroke.
RandomThe brush angle gets set random.

Brush Mapping with mapping method Stencil

The former methods uses the textures for the brush. The method Stencil works different. You have your texture displayed in the workspace above the object, and you paint this texture onto your object with your pencil strokes.

Note that the texture in the 3d space is just visible when you are with the mouse over the viewport.

It gets by default displayed down left. You have to position it where you need it.

Brush Mapping with mapping method Stencil
Brush Mapping with mapping method Stencil
Brush Mapping with mapping method Stencil
Brush Mapping with mapping method Stencil
EntryWhat it does
Image AspectAdjust the stencil size to fit to the image aspect ratio.
Reset TransformResets the stencil image to be down right in the 3D view.
Angle edit boxAdjust the angle of the brush. The button at the end allows you to set the radius by dragging the mouse. This should be done in the viewport and with the hotkey. This button is just a visible reminder.
OffsetFine tune the offset of the texture in the brush.
SizeFine tune the size of the texture in the brush.

Brush Settings Panel - Texture Mask Subanel

Brush Settings Panel - Texture Mask Subanel
Brush Settings Panel - Texture Mask Subanel

The texture mask subpanel allows you to use a texture as a mask to define the strength of painting. In the shot example we use a tiled fishscale Texture as a pencil, and a stencil map as our texture mask. And it paints just where the mask texture is bright. You can of course use gradients here to define the paint strength.

Brush Settings Panel - Texture Mask Subanel
Brush Settings Panel - Texture Mask Subanel

Browse Texture to be linked

Browse Texture to be linked
Browse Texture to be linked

The image at the top of the panel is a image browser. Choose a texture that you can choose for painting then. You can also have more than one image loaded at once.

Browse Texture to be linked
Browse Texture to be linked

In this shot there is already two textures added. The way to add the texture here is a bit more complicated. And not done with clicking at the New button.

First click at the New button below the image. This will create a new texture slot. This slot is still empty, it displays black.

We need to load a texture in this slot. This must be done in the Properties editor in the Textures tab.

The problem is, we have an object with a material and a texture already selected. And when we change this texture , then we don't get the pencil texture loaded. But we change the texture at our mesh.

What we need to do is to create a material first. And in this material we load our pencil texture then. And then we can choose this texture in the image browser of the texture.

Browse Texture to be linked
Browse Texture to be linked
Browse Texture to be linked
Browse Texture to be linked
Browse Texture to be linked
Browse Texture to be linked
Browse Texture to be linked
Browse Texture to be linked
Browse Texture to be linked
Browse Texture to be linked

And when we switch back to the tools tab, then the texture is loaded. And we can work with this texture.

Brush Mapping with mapping method Tiled

Brush Mapping with mapping method Tiled
Brush Mapping with mapping method Tiled

The brush mapping method Tiled tiles the brush stroke at the surface. The mapping happens from the current view. The result may be distorted when the view does not align with the surface of the object.

Brush Mapping with mapping method Tiled
Brush Mapping with mapping method Tiled

Pressure Masking

Pressure Masking

A dropdown box to choose the mask pressure mode for tablets.

EntryWhat it does
AngleThe angle of the brush.
OffsetThe offset of the texture in the brush.
SizeThe size of the texture in the brush.

Brush Mapping with mapping method View Plane

Brush Mapping with mapping method View Plane
Brush Mapping with mapping method View Plane

The brush mapping method View Plane simply paints onto the surface. The mapping happens from the current view. The result may be distorted when the view does not align with the surface of the object.

Brush Mapping with mapping method View Plane
Brush Mapping with mapping method View Plane

Pressure Masking

Pressure Masking

A dropdown box to choose the mask pressure mode for tablets.

EntryWhat it does
AngleThe angle of the brush. · Rake: The angle follows the direction of the brush stroke. · Random: The brush angle gets set random.
OffsetThe offset of the texture in the brush.
SizeThe size of the texture in the brush.

Brush Mapping with mapping method Random

Brush Mapping with mapping method Random
Brush Mapping with mapping method Random

The brush mapping method Random paints onto the surface, and randomizes the texture position in the brush while that. The mapping happens from the current view. The result may be distorted when the view does not align with the surface of the object.

Brush Mapping with mapping method Random
Brush Mapping with mapping method Random

Pressure Masking

Pressure Masking

A dropdown box to choose the mask pressure mode for tablets.

EntryWhat it does
AngleThe angle of the brush. · Rake: The angle follows the direction of the brush stroke. · Random: The brush angle gets set random.
OffsetThe offset of the texture in the brush.
SizeThe size of the texture in the brush.

Brush Mapping with mapping method Stencil

Brush Mapping with mapping method Stencil
Brush Mapping with mapping method Stencil

The former methods uses the textures for the brush. The method Stencil works different. You have your texture displayed in the workspace above the object, and you paint this texture onto your object with your pencil strokes.

Note that the texture in the 3d space is just visible when you are with the mouse over the viewport. Note that the texture in the 3d space is just visible when you are with the mouse over the viewport. It gets by default displayed down left. You have to position it where you need it.

Brush Mapping with mapping method Stencil
Brush Mapping with mapping method Stencil

Reset Transform

Resets the stencil transformation to default.

Pressure Masking

Pressure Masking

A dropdown box to choose the mask pressure mode for tablets.

EntryWhat it does
Angle edit boxAdjust the angle of the brush. The button at the end allows you to set the radius by dragging the mouse. This should be done in the viewport and with the hotkey. This button is just a visible reminder.
OffsetFine tune the offset of the texture in the brush.
SizeFine tune the size of the texture in the brush.

Brush Settings Panel - Stroke Sub panel

The Stroke panel contains settings to influence the behavior of the brush stroke. There are various stroke methods available. We will go through them one by one.

Stroke Panel with Stroke method Space

Stroke Panel with Stroke method Space
Stroke Panel with Stroke method Space

This is the default Stroke method. The sculpt stroke gets added continuously with given settings.

Stroke Panel with Stroke method Space
Stroke Panel with Stroke method Space

Spacing Edit Box

Spacing Edit Box

The sculpt drawing happens by mapping the pencil onto the mouse position. And when you move the mouse then the next mapping happens. Adjust the spacing after what mouse movement the next mapping should happen. The lower the value, the lower the distance between the single dots.

Spacing Pressure

The icon behind the edit box enables tablet pressure sensitivity for tablets.

EntryWhat it does
Adjust Strength for SpacingAutomatically adjust strength to give consistent results for different spacing.
Dash RatioRatio of samples in a cycle that the brush is covering.
Dash LengthLength of a dash cycle measured in stroke samples.
Jitter Edit BoxAdd Jitter to the brush while painting. · Spacing Pressure: The icon behind the edit box enables tablet pressure sensitivity for tablets. · Jitter Unit: Jitter in screen space, or relative to the brush size.
Input Samples Edit BoxAverage multiple input samples together to smooth the brush stroke.
Stabilize StrokeThe brush lags behind the mouse position, and produces a much smoother stroke by that. · Smooth Stroke Radius Edit Box: Is just active when Smooth Stroke is activated. Adjust the radius of the smoothing. · Smooth Stroke Factor Edit Box: Is just active when Smooth Stroke is activated. Adjust the factor of the smoothing.

Stroke Panel with Stroke method Curve

Stroke Panel with Stroke method Curve
Stroke Panel with Stroke method Curve

The Stroke method curve doesn't simply influence the way how the stroke is painted. It is a special method. First you draw a curve object by holding down ctrl and clicking with left mouse button. Then you tweak the curve. You can click at the curve point, and drag out handlers to make the curve points smooth.

Stroke Panel with Stroke method Curve
Stroke Panel with Stroke method Curve
Stroke Panel with Stroke method Curve
Stroke Panel with Stroke method Curve
Stroke Panel with Stroke method Curve
Stroke Panel with Stroke method Curve

Then you hit the Draw Curve button. And the curve gets drawn onto the surface.

Spacing Edit Box

Spacing Edit Box

The drawing happens by mapping the pencil onto the mouse position. And when you move the mouse then the next mapping happens. Adjust the spacing after what mouse movement the next mapping should happen. The lower the value, the lower the distance between the single dots.

The icon behind the edit box enables tablet pressure sensitivity for tablets.

Adjust Strength for Spacing

Automatically adjust strength to give consistent results for different spacing.

Paint Curve edit box

Here you set the active curve.

Paint Curve edit box
Paint Curve edit box

The first element is a drop down box where you will find your curves objects. You can have more than one.

The second element is the edit box that displays the active curve.

The number right of it, in this case 2, indicates how much number of users ( internally ) this brush uses. This means that this data block (the brush) shares currently settings with at least one other object. Most probably the parent brush where we have created it from. Click at the value to make this brush a single user. The button will vanish then.

F set the brush to have a fake user. Zero user data-blocks are normally not saved. But sometimes you want to force the data to be kept even when the data block has no user.

The + button allows you to add a new pencil with the current settings. Note that the brushes are NOT saved when you close Bforartists. You can save them into the current blend file. Or you can save the startup file. But be careful here. This saves everything else of the current state of Bforartists too.

The X button deletes the brush as the active one. It does NOT delete it from the brushes list.

EntryWhat it does
Draw Curve ButtonA click at it to turns the curve into a sculpt stroke.
Jitter Edit BoxAdd Jitter to the brush while painting. · Jitter Pressure: The icon behind the edit box enables tablet pressure sensitivity for tablets. · Jitter Unit: Jitter in screen space, or relative to the brush size.
Input Samples Edit BoxAverage multiple input samples together to smooth the brush stroke.

Stroke Panel with Stroke method Line

Stroke Panel with Stroke method Line
Stroke Panel with Stroke method Line

With Stroke method line you draw a line between a starting point and an endpoint. And when you release the mouse then the line gets sculpted.

Stroke Panel with Stroke method Line
Stroke Panel with Stroke method Line
Stroke Panel with Stroke method Line
Stroke Panel with Stroke method Line

Spacing Edit Box

Spacing Edit Box

The drawing happens by mapping the pencil onto the mouse position. And when you move the mouse then the next mapping happens. Adjust the spacing after what mouse movement the next mapping should happen. The lower the value, the lower the distance between the single dots.

The icon behind the edit box enables tablet pressure sensitivity for tablets.

EntryWhat it does
Adjust Strength for SpacingAutomatically adjust strength to give consistent results for different spacing.
Jitter Edit BoxAdd Jitter to the brush while painting. · Jitter Pressure: The icon behind the edit box enables tablet pressure sensitivity for tablets. · Jitter Unit: Jitter in screen space, or relative to the brush size.
Input Samples Edit BoxAverage multiple input samples together to smooth the brush stroke.

Stroke Panel with Stroke method Anchored

Stroke Panel with Stroke method Anchored
Stroke Panel with Stroke method Anchored

Click and drag to place a dot and to scale it.

Edge to edge

Drag Anchor Brush from edge to edge.

Edge to edge

Jitter Edit Box

Add Jitter to the brush while painting.

EntryWhat it does
Jitter PressureThe icon behind the edit box enables tablet pressure sensitivity for tablets.
Jitter UnitJitter in screen space, or relative to the brush size.
Input Sample Edit BoxAverage multiple input samples together to smooth the brush stroke.

Stroke Panel with Stroke method Airbrush

Stroke Panel with Stroke method Airbrush
Stroke Panel with Stroke method Airbrush

The stroke acts like an airbrush pencil. The dots gets placed randomly.

Stroke Panel with Stroke method Airbrush
Stroke Panel with Stroke method Airbrush
EntryWhat it does
Rate Edit BoxDefine the rate of the drawing.
Jitter Edit BoxAdd Jitter to the brush while painting. · Jitter Pressure: The icon behind the edit box enables tablet pressure sensitivity for tablets. · Jitter Unit: Jitter in screen space, or relative to the brush size.
Input Samples Edit BoxAverage multiple input samples together to smooth the brush stroke.
Stabilize StrokeThe brush lags behind the mouse position, and produces a much smoother stroke by that. · Smooth Stroke Radius Edit Box: Is just active when Smooth Stroke is activated. Adjust the radius of the smoothing. · Smooth Stroke Factor Edit Box: Is just active when Smooth Stroke is activated. Adjust the factor of the smoothing.

Stroke Panel with Stroke method Drag Dot

Stroke Panel with Stroke method Drag Dot
Stroke Panel with Stroke method Drag Dot

Paint a dot and drag it around. The actual painting happens then at releasing the mouse

EntryWhat it does
Jitter Edit BoxAdd Jitter to the brush while painting. · Jitter Pressure: The icon behind the edit box enables tablet pressure sensitivity for tablets. · Jitter Unit: Jitter in screen space, or relative to the brush size.
Input Samples Edit BoxAverage multiple input samples together to smooth the brush stroke.

Stroke Panel with Stroke method Dots

Stroke Panel with Stroke method Dots
Stroke Panel with Stroke method Dots

The stroke method Dots draws dots of the pencil onto the surface. The mapping happens from the current view. Means you will get distortions when your view is not aligned with the surface of the object.

Jitter Edit Box

Add Jitter to the brush while painting.

Jitter Pressure
Jitter Pressure

The icon behind the edit box enables tablet pressure sensitivity for tablets.

Jitter Unit

Jitter in screen space, or relative to the brush size.

EntryWhat it does
Input Samples Edit BoxAverage multiple input samples together to smooth the brush stroke.
Stabilize StrokeThe brush lags behind the mouse position, and produces a much smoother stroke by that.
Smooth Stroke Radius Edit BoxIs just active when Smooth Stroke is activated. Adjust the radius of the smoothing.
Smooth Stroke Factor Edit BoxIs just active when Smooth Stroke is activated. Adjust the factor of the smoothing.

Brush Settings Panel - Falloff Sub panel

Brush Settings Panel - Falloff Sub panel
Brush Settings Panel - Falloff Sub panel

The Falloff panel allows you to define different falloffs methods for the border of the brush.

Presets

Presets

The different available falloff presets. The method custom allows you to define your own falloff. And reveals a curve panel.

Selecting Points

Selecting Points

You can select curve points. This reveals two edit boxes for the x and y coordinate of this point.

Selected points can be moved around. Left click at them, hold the mouse button down and move them to a new location.

Adding Points

Adding Points

You can add new curve points by simply left clicking at the curve. Move the mouse to position them where you need it.

Navigation elements

The navigation elements at the top are described from left to right.

EntryWhat it does
Zoom in and outThe two buttons with the magnifying glass at it zooms in and out in the curve window.
ToolsTools is a menu where you can find some curve related tools. · Reset View: Resets the curve windows zoom. · Vector Handle: Set handle type to Vector. · Auto Handle: Set handle type to Auto. · Auto Clamped Handle: Set handle type to Auto Clamped. · Reset Curve: Resets the curve to the initial shape.

Use Clipping

Use Clipping

Clipping options. Set up clipping for the stroke. The blue button at the top turns clipping on or off.

Delete Points

Deletes the selected curve point.

Curve Presets

Curve Presets

Predefined curve presets as a starting point.

Normal Falloff

Angle
Angle

Adjust the angle.

Brush Settings Panel - Cursor Sub panel

Brush Settings Panel - Cursor Sub panel
Brush Settings Panel - Cursor Sub panel

Adjust the color and appearance of the brush cursor to custom values.

Cursor Checkbox

Activate the custom settings.

Cursor Color

Cursor Color

Choose another color for the brush cursor. Double clicking at the color field will open a color picker.

Falloff Opacity

Falloff Opacity

You can turn on the cursor overlay with the eye button at the end. The falloff opacity slider allows you to adjust the opacity of this cursor overlay.

EntryWhat it does
Override OverlayHide the Cursor Overlay when painting.
Use Cursor OverlayTurn on Cursor Overlay.

Texture Opacity

This is for the case when you paint with a texture brush. You can turn on the Texture overlay with the eye button at the end. The falloff opacity slider allows you to adjust the opacity of this cursor overlay.

EntryWhat it does
Override OverlayHide the Texture Overlay when painting.
Use Cursor OverlayTurn on Texture Overlay.

Mask Texture Opacity

This is for the case when you mask paint with a texture brush. You can turn on the Texture overlay with the eye button at the end. The falloff opacity slider allows you to adjust the opacity of this cursor overlay.

EntryWhat it does
Override OverlayHide the Texture Overlay when painting.
Use Cursor OverlayTurn on Texture Overlay.

Brush Settings Panel - Clone from Paint Slot Sub panel

Brush Settings Panel - Clone from Paint Slot Sub panel
Brush Settings Panel - Clone from Paint Slot Sub panel

This panel is just for the clone tool in the tool shelf.

Activate to clone from the current texture. For the clone tool description see tool shelf. Here you just can activate, then see or choose the material to clone from. It is a list.

Symmetry Panel

Symmetry Panel

Symmetry Panel

Turn on/off symmetry painting along X, Y and Z axis. The mirroring happens along the world axis.

Symmetry Panel

The same buttons can also be found in the tool settings bar as icon buttons. This allows quicker access and better visual control which mirror axis is currently active.

Symmetry Panel

Options Panel

Options Panel
EntryWhat it does
BleedAn edit box to adjust the amount of bleeding into the areas outside of the faces UV.
DitherAn Edit box to adjust the amount of dither when painting on byte images
OccludeOnly paint the faces directly under the mouse.
Backface CullingIgnore faces that are painting away from the viewport.

External

External

The external sub panel allows you to do projection painting by using an external 2d image editor. The projection happens from the current view. So this can lead to distortions.

EntryWhat it does
Screen Grab SizeSet the resolution of the shot.
Quick EditOpens a shot of the current view in your 2D Image Editor.
ApplyApplies the changes that you made and saved in your 2D Image Editor.
Apply Camera ImageProject an edited render from the active camera back onto the object. This feature requires to have a background image loaded. Then this background image can be projected onto the object from the camera view.

Workflow for external editing

Workflow for external editing
Workflow for external editing
Preparations

You first have to link your software that you want to use here. When there is no image editor linked then you will get a warning.

Open the User Preferences, go to the File tab. Here choose the Image Editor section, and browse for your image editor. I have chosen Gimp here at Windows 7.

Don't forget to save the User Settings!

For further options have a look in the Project Paint panel.

Usage
Usage

Click at the Quick Edit Button. And your image editor will open up with a shot from the current view. Modify your image.

When done simply overwrite the image. Sorry for the german shot ...

Usage

Back in Bforartists click at the Apply button. And the result gets mapped onto your object.

Attention, don't change the camera view while doing this. Mapping happens from the current camera view!