View & accessibility
Thumbnails
Motion
Bforartists
5.1
Editors

Particle Edit

Comb, cut and style particle hair: menus, tools and settings.

8
 min read
Up to date for 
5.1
draft

Mesh › Particle Edit: every menu, tool, sidebar tab and context menu of this mode, on one page. Use the panels on the right to jump between the regions.

Header

Particle menu

Particle Mode - Particle Menu

Particle Mode - Particle Menu
Particle Mode - Particle Menu

Mirror

Mirror

Mirrors the selected particles.

If you want a symmetrical haircut, first select all particles, then mirror the particles, then tick X Mirror in the Particle panel.

EntryWhat it does
Remove DoublesRemove double vertices that are very close to each other. This can for example happen when you mirror the particles.
Unify LengthUnifies the length of the selected hair particles. The length is calculated by the average length of the selection.

Rekey

You need to have some hair particles selected.

Rekey

Rekey changes the number of keys for the selected particles, including root and tip keys. This tool brings up a popup where you can adjust the number of keys. Two means you have only a root and a tip key. Everything more subdivides the selected hair particle with more keys.

Weight Set

Manually set a weight for the selected keys to interpolate between the current key weight and the brushes weight.

Last Operator Weight Set
Factor
Factor

The strength of the keys weighting.

Delete

Delete

Delete either the whole particle, or just the selected key of the particle.

Show/Hide - Submenu

Show or hide the selected geometry

EntryWhat it does
Show HiddenMakes all hidden geometry visible again.
Hide SelectedHides the selected geometry.
Hide UnselectedHides the not selected geometry. The selected geometry stays visible.
Last Operator Hide Selected
Last Operator Hide Selected
Last Operator Hide Selected

Each of the menu items uses the same Last Operator. With different strings for the booleans.

Unselected

Hide the unselected geometry instead the seleced.

Tool Shelf

Tools

Tool Shelf - Mesh - Particle Edit Mode

Tool Shelf - Mesh - Particle Edit Mode
Tool Shelf - Mesh - Particle Edit Mode

You can attach a particle system to a mesh object. And then you can switch to a Particle Edit Mode.

This mode allows you to edit the particles. In the tool shelf you will find several brushes. These brushes are of use for particles of type hair. They can be combed, cut etc. .

Select and 3D Cursor tools

Select tools group and 3D Cursor are explained in the chapter 7.1.1 Editors - 3D View - Tool Shelf - Object Mode. We won't cover this tools again here.

Hotkeys

Hotkeys

Pressing F allows you to change the brush size onscreen. Drag the mouse to increase or decrease the size. Left click applies the new size, right click cancels the resizing.

Hotkeys

Pressing Shift F allows you to change the strength of the brush. Drag the mouse to increase or decrease the size. Left click applies the new size, right click cancels the resizing.

Comb

Allows you to comb the strands of the particle system.

Tool Settings
Tool Settings
EntryWhat it does
RadiusThe brush radius. The button behind the edit box allows you to set the radius by mouse move. This is a hotkey tool, and should be performed in the viewport.
StrengthThe brush strength. The button behind the edit box allows you to set the radius by mouse move. This is a hotkey tool, and should be performed in the viewport.
Deflect EmitterPrevent paths to intersect the emitter mesh geometry.
DistanceThe distance to keep particles away from the emitter mesh geometry.
Smooth

Allows you to smooth the strands of the particle system.

Tool Settings
Tool Settings
EntryWhat it does
RadiusThe brush radius. The button behind the edit box allows you to set the radius by mouse move. This is a hotkey tool, and should be performed in the viewport.
StrengthThe brush strength. The button behind the edit box allows you to set the radius by mouse move. This is a hotkey tool, and should be performed in the viewport.
Add

Allows you to add strands to the particle system.

Tool Settings
Tool Settings
EntryWhat it does
RadiusThe brush radius. The button behind the edit box allows you to set the radius by mouse move. This is a hotkey tool, and should be performed in the viewport.
CountThe amount of strands.
InterpolateInterpolate new particles from the existing ones.
StepsBrush steps. Steps is connected with Interpolate.
KeysHow many keys to make new particles with.
Length

Manipulate the length of the strands.

Tool Settings
Tool Settings
EntryWhat it does
RadiusThe brush radius. The button behind the edit box allows you to set the radius by mouse move. This is a hotkey tool, and should be performed in the viewport.
StrengthThe brush strength. The button behind the edit box allows you to set the radius by mouse move. This is a hotkey tool, and should be performed in the viewport.
Length ModeGrow or shrink the particles.
Puff

Manipulate the volume of the strands.

Tool Settings
Tool Settings
EntryWhat it does
RadiusThe brush radius. The button behind the edit box allows you to set the radius by mouse move. This is a hotkey tool, and should be performed in the viewport.
StrengthThe brush strength. The button behind the edit box allows you to set the radius by mouse move. This is a hotkey tool, and should be performed in the viewport.
Add / SubAdd or subtract to the current volume.
Puff VolumeApply Puff to unselected end points.
Cut

Cut away particles.

Tool Settings
Tool Settings
EntryWhat it does
RadiusThe brush radius. The button behind the edit box allows you to set the radius by mouse move. This is a hotkey tool, and should be performed in the viewport.
StrengthThe brush strength. The button behind the edit box allows you to set the radius by mouse move. This is a hotkey tool, and should be performed in the viewport.
Weight

Manipulate the weight of the strands.

Tool Settings
Tool Settings
EntryWhat it does
RadiusThe brush radius. The button behind the edit box allows you to set the radius by mouse move. This is a hotkey tool, and should be performed in the viewport.
StrengthThe brush strength. The button behind the edit box allows you to set the radius by mouse move. This is a hotkey tool, and should be performed in the viewport.

Sidebar

Particle Edit Mode

Tools Tab in Particle Edit Mode

Tools Tab in Particle Edit Mode
Tools Tab in Particle Edit Mode

The Particle Edit mode enables to edit particle settings. For example, Hair Particles can be manipulated with some brushes. They can be combed, cut etc.

The Tools tab contains the settings for the hair editing brushes.

Different from the other paint modes, there is no brush panel. The brushes are here part of the tool settings of the single brushes.

The brush settings can be found in the Particle Tool panel instead.

Particle Edit Mode - Particle Tool panel

Comb brush

Comb brush
EntryWhat it does
RadiusThe size of the brush.
StrengthThe strength of the brush.
Deflect EmitterKeep paths from intersecting the emitter.
DistanceDistance to keep particles away from emitter.

Smooth brush

Smooth brush
EntryWhat it does
RadiusThe size of the brush.
StrengthThe strength of the brush.

Add brush

Add brush
EntryWhat it does
RadiusThe size of the brush.
StrengthThe strength of the brush.
InterpolateInterpolate new particles from existing ones.
StepsBrush steps.
KeysHow many keys to make new particles with.

Length brush

Length brush
EntryWhat it does
RadiusThe size of the brush.
StrengthThe strength of the brush.
LengthMake hairs longer with Grow, or shorter with Shrink.

Puff brush

Puff brush
EntryWhat it does
RadiusThe size of the brush.
StrengthThe strength of the brush.
Puff ModeAdd makes hairs more puffy. Sub (tract) makes hairs less puffy.

Cut brush

Cut brush
EntryWhat it does
RadiusThe size of the brush.
StrengthThe strength of the brush.

Weight brush

Weight brush
EntryWhat it does
RadiusThe size of the brush.
StrengthThe strength of the brush. hier weiter

Particle Edit Mode - Options panel

Particle Edit Mode - Options panel
Particle Edit Mode - Options panel

This panel contains some further options for the particles.

Particle Edit Mode - Options panel
Particle Edit Mode - Options panel
Particle Edit Mode - Options panel
Particle Edit Mode - Options panel

Note that you need to bake some particle types to be able modify them. Emitter for example. You will get a warning then, and the Options panel content is greyed out.

The particles can be baked in the Particles tab in the Cache panel.

Particle Edit Mode - Options panel
Particle Edit Mode - Options panel
EntryWhat it does
Editing TypeThe Particle Edit Type. This edit box just shows you what particle type you currently have. It does not allow you to change the particle type.
X MirrorMirrors the selected particles. If you want a symmetrical haircut, first select all particles, then mirror the particles, then tick X Mirror.
PreserveStrand Lengths: Keep the path lengths constant. · Root Positions: Keep root keys unmodified.

Cut particles to Shape

Cut particles to Shape
Cut particles to Shape

Define an object to cut the hair particles into the shape of the object.

The Cut button with which you perform the option becomes active when you choose a shape object from the list, or pick it in the scene.

Viewport Display

Viewport Display
With Hair
EntryWhat it does
Path StepsHow many steps to display the path with. Meant is the resolution for the hair strains.
ChildrenDisplay all particles, including children. For performance reasons child particles are usually not displayed in the viewport.
With Emitter
With Emitter

The emitter particle system must be editable, or the settings remains greyed out. Bake ...

EntryWhat it does
Path StepsHow many steps to display the emitter path with.
ParticlesDisplay the actual particles.
Fade TimeFade paths and keys further away from the current frame
FramesHow many frames to fade.