View & accessibility
Thumbnails
Motion
Bforartists
5.1
Editors

Context Menus

The right-click menus of Mesh › Edit Mode.

40
 min read
Up to date for 
5.1
draft

Edge Context Menu

Edge Context Menu

Edge Context Menu
Edge Context Menu

Call this menu with double right click in the 3D viewport. You need to be in Edit mode with a Mesh object. And in selection mode Edge.

Edge Context Menu

Select geometry to reveal all content.

Subdivide

Subdivide
Subdivide

Subdivide divides the selected edges. It subdivides the involved faces too, and can create new vertices.

A more unknown functionality is that it can also randomize the result with the Fractal slider in the Last operator panel.

Last Operator Subdivide

Last Operator Subdivide
Number of Cuts

The number of cuts defines the amount of subdivisions.

Smoothness
Smoothness

This value defines how smooth the subdivision result is. From flat to bent.

Create N-Gons

Create N-Gons if required. Else subdividing N-Gons creates Tris.

Quad Corner Type
Quad Corner Type

Adjust the corner type.

EntryWhat it does
FractalRandomize the selected vertices.
Along NormalWhen randomized, this value defines how strong the subdivision follows the normals of the initial vertices.
Random SeedRandomizing value for fractal randomizing.

Extrude Edges

Extrudes out the selected edges by moving the mouse.

Last Operator Extrude Only Edges and Move

Last Operator Extrude Only Edges and Move
Last Operator Extrude Only Edges and Move
EntryWhat it does
Flip NormalsFlip the normals at the involved faces.
Move X Y ZThe coordinates for the extruded geometry.

Orientation

Orientation

Choose the type of orientation, in which coordinate system the action should happen.

EntryWhat it does
Constraint Axis—
Mirror EditingEnable mirror editing.

Proportional editing

Proportional editing

Enables proportional editing. Activating proportional editing reveals further settings.

EntryWhat it does
Proportional FalloffAdjust the falloff methods.
Proportional SizeSee and adjust the falloff radius.
ConnectedThe proportional falloff gets calculated for connected parts only.
Projected(2D)The proportional falloff gets calculated in the screen space. Depth doesn't play a role. When it's in the radius, then it gets calculated.

Bevel Edges

Bevel Edges

Adds a bevel at the selected edges.

Last Operator Bevel

Last Operator Bevel
Affect

Affect vertices or edges.

Width Type
Width Type

The width type.

EntryWhat it does
WidthThe bevel amount.
SegmentsHow many segments gets created.
Profile ShapeControls the Profile shape. 0.5 means round.
Material IndexAssigns a material slot to the new bevel faces. -1 is the surrounding material.
Harden Normals

When enabled, the per-vertex face normals of the bevel faces are adjusted to match the surrounding faces, and the normals of the surrounding faces are not affected. This will keep the surrounding faces flat (if they were before), with the bevel faces shading smoothly into them. For this effect to work, custom split normals need to be enabled, which requires Auto Smooth to be enabled (see Normals). As a convenience, that option will be enabled for you if it is not already when you enable Harden Normals here.

EntryWhat it does
Clamp OverlapDo not allow beveled geometry to overlap each other. Prevents bevel geometry from intersecting itself. Helps avoid messy geometry in tight corners.
Loop SlideSlides new edges along adjacent geometry for better topology flow
MarkSeams: Mark the edges of the new created geometry as seams. · Sharp: Mark the edges of the new created geometry sharp.
Miter Type
Miter Type
Miter Outer

How the outer miter is set. Miter is how the bevel rounding at a corner is done.

Sharp

Sharp

Creates a sharp miter.

Patch

Patch

This replaces the outside vertex of a miter with 3 vertices. And uses a patch pattern there.

Arc

Arc

This replaces the vertex of a miter with 2 vertices, joined by an arc. A separate Spread parameter says how far to move the vertices away from their original position.

Inner Miter
Inner Miter

How the inner miter is set. Miter is how the bevel rounding at a corner is done.

Sharp

Sharp

Creates a sharp miter.

Arc

Arc

This replaces the vertex of a miter with 2 vertices, joined by an arc. A separate Spread parameter says how far to move the vertices away from their original position.

Spread

Spread

Belongs to inner miter method Arc. Adjust how strong the inner radius is bent.

Intersection type
Intersection type

The method to use to create meshes at intersections. Bevel can create self intersecting geometry.

EntryWhat it does
Grid FillFills intersections with a grid-like topology.
CutoffTrims or removes overlapping geometry at intersections
Face Strength
Face Strength

Set Face Strength on the faces involved in the bevel, according to the specified mode. This can be used in conjunction with a Weight Normals Modifier (with the Face Influence option checked).

EntryWhat it does
NoneDo not set face strength.
NewSet the face strength of new faces along edges to Medium, and the face strength of new faces at vertices to Weak.
AffectedIn addition to those set for the New case, also set the faces adjacent to new faces to have strength Strong.
AllIn addition to those set for the Affected option, also set all the rest of the faces of the model to have strength Strong.
Profile Type
Profile Type

The profile type.

Superellipse

Uses a mathematically smooth curve for bevel profiles

Custom

Allows manual control of the bevel profile shape via a curve widget.

Presets

Presets

Curve presets.

Navigation elements

EntryWhat it does
Zoom in and outThe two buttons with the magnifying glass at it zooms in and out in the curve window.
Reverse PathReverses the curve path.
Toggle Profile ClippingTurns the profile clipping on or off.

Tools menu

Tools menu
EntryWhat it does
Reset ViewResets the curve windows zoom.
Reset CurveResets the curve to the initial shape.
Curve view
Curve view

Adjust the profile curve.

Left click where no point is adds a new point. Left click at a point allows you to move it.

Holding down Shift while moving a node point activates precision movement.

Holding down ctrl while moving activates temporary snapping.

When a point is selected then the curve view reveals a sub menu at the bottom.

Handler and node position

Handler and node position
Handler and node position

When you select a node, then the handler and node position tools shows below the curve window.

EntryWhat it does
Handle Type Auto HandleSets the handle type of this curve point to smooth.
Handle Type Vector HandleSets the handle type of this curve point to sharp.
Handle Type Free HandleSets the handle type of this curve to Free handles. The curve point has now two handles with which you can adjust the curve before and after the point each.
Handle Type Aligned Free HandleSets the handle type of this curve to Free handles. The curve point has now a handle with which you can adjust the curve.
X Y ValuesThe position of the currently selected curve point
EntryWhat it does
Sample straigt edgesSample edges with vector handles.
Sample even lengthSample edges with even lengths.

Make Edge/Face

Adds a face when you have edges selected. And Edges when you have Vertices selected. It's a Bridge tool.

You can have either the one method or the other. When you select two adjacent vertices, then you select the edge too. And the tool works in edge mode then. In this case just the possible faces gets created. Not edges between single vertices.

First select the edges or Vertices that you want to bridge. Then click the New Edge/Face from Vertices Button.

Make Edge/Face
Make Edge/Face
Make Edge/Face
Make Edge/Face

Bridge Edge loops

Bridge Edge loops

The Bridge edge loops tool bridges selected edges, and adds a polygon between them. You need to have at least two edges selected.

Last Operator Bridge Edge loops

Last Operator Bridge Edge loops
Last Operator Bridge Edge loops
EntryWhat it does
Connect LoopsChoose the method how to deal with bridging multiple loops.
MergeWith merge ticked it will not create a bridge face, but merge the selected edges. · Merge Factor: The merge factor determines at which distance between the selected edges the merge happens. 0.5 is the middle of the selected edges.
TwistThe twist offset for closed loops.
Number of CutsAdds cuts to the bridge face.
InterpolationChoose the interpolation mode for the cuts.
SmoothnessAdjust the smoothness for the cuts.
Profile FactorAdjust the profile factor for the cuts.
Profile shapeAdjust the profile shape for the cuts.

Fill

Fill

Fill closes holes in the selected mesh geometry, and triangulates the faces.

Last Operator Fill

Beauty
Beauty

Uses the best possible triangulation.

Loop Cut and Slide

Loop Cut and Slide
Loop Cut and Slide

Loop Cut and Slide adds edge loops to divide faces

When you click once, then this edge gets created. When you click and hold, then you can move this edge to a new location.

Loop cut and Slide ignores selections. It will try to divide the face under the mouse, and continue the loop until it is closed, or until it cannot continue.

Last Operator Loop Cut and Slide

Last Operator Loop Cut and Slide
Last Operator Loop Cut and Slide

Note that all settings here just changes the latest added loop. Not all added loops in the current session.

Number of Cuts

The number of cuts that gets added. It can be more than one loop at once.

Smoothness
Smoothness

This value defines how smooth the loop cut gets added. From flat to bent.

Falloff
Falloff

Adjust the Falloff type for smoothness.

EntryWhat it does
FactorChange the center of the added loop.
EvenMake the edge loop match the shape of the adjacent edge loop
FlippedWhen Even mode is active, flips between the two adjacent edge loops.
ClampClamp within the edge extend.
Mirror EditingEnable mirror editing.
Correct UV'sCorrects the UV's when modifying the geometry.

Offset Edge Slide

Offset Edge Slide

Adds left and right an edge from the selected edge and slides it outwards.

Last Operator Offset Edge Slide

Last Operator Offset Edge Slide
Last Operator Offset Edge Slide
Cap Endpoint
Cap Endpoint

Connects the endpoints of the slided edges.

EntryWhat it does
FactorThe amount of sliding.
EvenMake the edge loop match the shape of the adjacent edge loop
FlippedConnected with Even. When even mode is active then flips between the two adjacent edge loops.
ClampClamp within the edge extends.
Mirror EditingEnable mirror editing.
Correct UV'sCorrect UV coordinates when transforming.

Knife Topology

Knife Topology

The Knife tool cuts the geometry, and adds edges. When it crosses existing geometry then it adds a vertice at the crossing point.

Usage: activate the tool, left click to define the starting point. This can also be a point in the middle of a face. But ideally you choose an existing vertice or an edge as the start and endpoints. The knife tool tries to snap to them when you get close with the mouse cursor.

When done press Enter or Space bar to confirm. Right click abandons the operation.

When you create a vertice in the middle of a face, then the knife tool will try to connect this vertice by an existing vertice of this face when you confirm with space bar.

Hotkey functionality in the footer text
Hotkey functionality in the footer text

Have a look at the footer when you work with this tool. Here you will find further instructions and hotkeys.

Enter, Pad Enter, Space bar - confirm

Esc key, RMB - cancel the operation

LMB start the cut

Double LMB - close the cut

E - create new cut

Ctrl or Shift while dragging - Snap to the middle of an edge

Z - cut through the whole geometry, also the back faces.

MMB - pan the view.

Alt MMB - rotate the view.

Rotate Edge CW

Rotate Edge CW

Rotate Edge rotates the selected edge clockwise.

Last Operator Rotate Selected Edge

Counter Clockwise
Counter Clockwise

Rotate selected edges counter clockwise.

Edge Split

Edge Split

Splits selected edges so that each neighbor face gets its own copy. You have two methods here.

Last Operator Edge Split

Last Operator Edge Split
Last Operator Edge Split
Type

Choose the method again.

Edge Crease

Edge Crease

When you use a Subdivision Surface Modifier, then you can define the sharpness of selected edges with this tool. Crease edges will be marked colored in edit mode.

You will see a value in the header that indicates the current strength when you activate the tool. Move with the mouse to increase or decrease the value. Or type in a value while you are in this mode. You can also scale into negative range.

Edge Crease

A negative crease value will subtract from the current active crease value in case it exists already from a former crease operation. A Crease value of -1 removes the crease from this edge.

Last Operator Edge Crease

Last Operator Edge Crease
Last Operator Edge Crease
Factor

Adjust the crease factor.

Edge Bevel Weight

Edge Bevel Weight
Edge Bevel Weight

This tool adjusts the edge bevel weight for selected edges when you use the Bevel modifier at the mesh.

You need to have set the limit method to Weight. This way you can achieve a bevel weight for every individual selected edge if you want, and achieve different bevel strengths at the mesh.

You will see a value in the header that indicates the current strength when you activate the tool. Move with the mouse to increase or decrease the value. Or type in a value while you are in this mode. You can also scale into negative range.

Edge Bevel Weight

A negative Edge Bevel Weight value will subtract from the current active crease value in case it exists already from a former crease operation. An Edge Bevel Weight value of -1 removes the weight from this edge.

Last Operator Edge Bevel Weight

Factor
Factor

Adjust the Edge Bevel Weight factor.

Mark Sharp

Mark Sharp

Mark Sharp is a tool that you need for the Edge Split modifier. Marked edges are displayed and rendered as sharp edges.

Mark Sharp

Last Operator Mark Sharp

Last Operator Mark Sharp
Last Operator Mark Sharp
Vertices

Calculate by the selected vertices instead of edges to mark the edges.

Clear Sharp

Clears formerly as sharp marked selected edges.

Last Operator Mark Sharp

Last Operator Mark Sharp
Last Operator Mark Sharp
Vertices

Calculate by the selected vertices instead of edges to mark the edges.

Set sharpness by Angle

Sets the sharpness of edges by their angle to the neighbour face.

Last Operator Set sharpness by Angle

Last Operator Set sharpness by Angle
Last Operator Set sharpness by Angle
EntryWhat it does
AngleThe angle after which the edge counts as sharp.
ExtendAdd new sharp edges without clearing existing sharp edges.
EntryWhat it does
Mark Freestyle EdgeMark the selected edges as a Freestyle feature edges.
Clear Freestyle EdgeClears formerly as freestyle feature edges marked edges.

Un-Subdivide

Un-Subdivide

Decimates the geometry by trying to make one quad out of four quads. But can also end in Tris where this is not possible.

Last Operator Un-Subdivide

Iterations
Iterations

Number of iterations. This means how deep the calculation should go. One level of SDS, two levels, three levels, etc. . Down to the point where you cannot decimate any geometry anymore.

Split

Splits the edges between the selected vertices. It creates two edges out of one. And splits the edge by that.

Separate submenu

Separate submenu

Separate separates the selected geometry, and creates a new object. The geometry becomes uneditable, since it is now a new object. You will have to leave the Edit mode, select the new object, and re-enter Edit mode when you want to edit it.

EntryWhat it does
SelectionSelection separates the current selection.
By MaterialBy Material separates all geometry that has the same material than the current selection.
By Loose PartsBy Loose parts separates all geometry that is connected by edges to the current selection.

Dissolve Edges

Dissolve Edges dissolves the selected edges.

Note that pressing Del in Vertice select mode calls Dissolve Vertices already. It's the same operator. But you don't get the Last operator that way.

Last Operator Dissolve Edges

Last Operator Dissolve Edges
Last Operator Dissolve Edges
EntryWhat it does
Dissolve VerticesDissolve remaining vertices which connect to only two edges.
Angle thresholdRemaining vertices which separate edge pairs are preserved if their edge angle exceeds this threshold.
Face SplitSplit off Face corners to maintain surrounding geometry

Delete Edges

Deletes the selected Edges.

Show/Hide

Show/Hide

Sub-menu with shows or hide selection, unselected or hidden operators.

Show Hidden

Makes all geometry in the scene visible again.

Hide Selected

Hides the selected geometry.

Last Operator Hide Selected
Last Operator Hide Selected
Last Operator Hide Selected
Unselected

Hides the not selected geometry.

Hide Unselected

Hides the not selected geometry. The selected geometry stays visible.

Face Context Menu

Face Context Menu

Face Context Menu

Call this menu with double right click in the 3D viewport. You need to be in Edit mode with a Mesh object. And in selection mode Edge.

Face Context Menu
Face Context Menu

Select geometry to reveal all content.

Subdivide

Subdivide
Subdivide

Subdivide divides the selected edges. It subdivides the involved faces too, and can create new vertices.

A more unknown functionality is that it can also randomize the result with the Fractal slider in the Last operator panel.

Last Operator Subdivide

Last Operator Subdivide
Number of Cuts

The number of cuts defines the amount of subdivisions.

Smoothness
Smoothness

This value defines how smooth the subdivision result is. From flat to bent.

Create N-Gons

Create N-Gons if required. Else subdividing N-Gons creates Tris.

Quad Corner Type
Quad Corner Type

Adjust the corner type.

EntryWhat it does
FractalRandomize the selected vertices.
Along NormalWhen randomized, this value defines how strong the subdivision follows the normals of the initial vertices.
Random SeedRandomizing value for fractal randomizing.

Extrude Faces

Extrudes out the selected faces into the face direction by moving the mouse. When it's more than one face, then the middle will be used.

Last Operator Extrude Region and Move

Last Operator Extrude Region and Move
Last Operator Extrude Region and Move
EntryWhat it does
Flip NormalsFlips the normals of the extruded faces.
Dissolve Orthogonal EdgesDissolves orthogonal edges.
Move X, Y ZThe position. Attention, the actual world orientation and rotation does not matter here. It always starts with a value of zero, and moves relative to this zero then. For the actual location values have a look in the sidebar in the transform panel.
Orientation
Orientation

The widget can have different orientations. The menu items should be self explaining.

Mirror Editing

Enable mirror editing.

Proportional editing
Proportional editing

Enables proportional editing. Activating proportional editing reveals further settings.

EntryWhat it does
Proportional FalloffAdjust the falloff methods.
Proportional SizeSee and adjust the falloff radius.
ConnectedThe proportional falloff gets calculated for connected parts only.
Projected(2D)The proportional falloff gets calculated in the screen space. Depth doesn't play a role. When it's in the radius, then it gets calculated.

Extrude Faces Along Normals

Extrude Faces Along Normals
Extrude Faces Along Normals

Extrudes the selection along local normals.

Header Value

Header Value

This tool works like a shrink fatten extrude. And so you will see a corresponding set of values in the header.

Last Operator Extrude Region and Shrink/Fatten

Last Operator Extrude Region and Shrink/Fatten
Last Operator Extrude Region and Shrink/Fatten
EntryWhat it does
Flip NormalsFlips the normals of the extruded faces. · Dissolve Orthogonal Edges: Dissolves orthogonal edges.
OffsetThe current extrude amount.
Offset EvenScales the offset to give more even thickness. Without this checked the farer away faces will have a bigger extrude amount.
Mirror EditingEnable mirror editing.
Proportional editing
Proportional editing

Enables proportional editing. Activating proportional editing reveals further settings.

EntryWhat it does
Proportional FalloffAdjust the falloff methods.
Proportional SizeSee and adjust the falloff radius.
ConnectedThe proportional falloff gets calculated for connected parts only.
Projected(2D)The proportional falloff gets calculated in the screen space. Depth doesn't play a role. When it's in the radius, then it gets calculated.

Extrude Individual

Extrude Individual

Extrudes the selection along local normals of each individual face.

The method works the same in all Mesh select modes. Vertice, Edge and Face Mode.

Header Value

Header Value

This tool works like a shrink fatten extrude. And so you will see a corresponding set of values in the header.

Last Operator Extrude Individual Faces and Move

Last Operator Extrude Individual Faces and Move
Last Operator Extrude Individual Faces and Move
EntryWhat it does
OffsetThe current extrude amount.
Offset EvenScales the offset to give more even thickness. Without this checked the farer away faces will have a bigger extrude amount.
Proportional editing
Proportional editing

Enables proportional editing. Activating proportional editing reveals further settings.

EntryWhat it does
Proportional FalloffAdjust the falloff methods.
Proportional SizeSee and adjust the falloff radius.
ConnectedThe proportional falloff gets calculated for connected parts only.
Projected(2D)The proportional falloff gets calculated in the screen space. Depth doesn't play a role. When it's in the radius, then it gets calculated.

Inset Faces

Inset Faces

Inset insets edges into the selected faces. Think of it as an extrude inwards the face.

Activate the tool, drag the mouse. But carefully. The control is not the best. You better adjust the amount in the last operator.

Last Operator Inset Faces

Last Operator Inset Faces
Last Operator Inset Faces
Boundary

With Boundary ticked you will get the connect edges in the corners. Without the edges ends straight.

Boundary
EntryWhat it does
Offset EvenScales the offset to give more even thickness.
Offset RelativeScales the offset by surrounding geometry.
Edge RailInset the region along existing edges.
ThicknessThickness adjusts the thickness of the inset geometry.
DepthWith depth you can bevel the inset geometry. It is then not longer co planar to the initial face.
OutsetWith outset ticked the Inset will not extrude inwards but outwards.
Select OuterWith Select Outer the outer ring will be selected after the Inset.
IndividualInset every face individually.
InterpolateBlend Face Data across the inset.

Bridge Faces

The Bridge Faces tool bridges selected faces, and adds polygons between them. You need to have at least two faces selected.

This tool is basically the Bridge Edge Loops tool, just that it operates in Face mode.

Note that this tool just shows when you are in Face Select Mode.

Last Operator Bridge Edge loops

Connect Loops

Choose the method how to deal with bridging multiple loops.

Merge
Merge

With merge ticked it will not create a bridge face, but merge the selected edges.

Merge Factor

The merge factor determines at which distance between the selected edges the merge happens. 0.5 is the middle of the selected edges.

EntryWhat it does
TwistThe twist offset for closed loops.
Number of CutsAdds cuts to the bridge face.
InterpolationChoose the interpolation mode for the cuts.
SmoothnessAdjust the smoothness for the cuts.
Profile FactorAdjust the profile factor for the cuts.
Profile shapeAdjust the profile shape for the cuts.

Poke Faces

Poke Faces

Splits the selected faces to create a triangulated geometry.

Last Operator Poke Faces

Poke Offset
Poke Offset

Normally the center vertice of the poke operation is planar with the rest. Adjust an offset.

Offset Relative

Scale the offset by surrounding geometry.

Offset Relative
Poke Center
Poke Center

Poke Center is a drop-down box choose what the center of the poke operation should be. You can choose between weighted mean, mean and bounds.

UV Unwrap Faces submenu

UV Unwrap Faces submenu
UV Unwrap Faces submenu

The UV menu from the header.

Here you find the UV mapping methods and some further functionality. You use it best in the U Editing layout. There you can see the result in the UV Editor then.

The UV menu is just available for Mesh objects

EntryWhat it does
Unwrap ABFUnwrap ABF unwraps the selected geometry with the method Angle based. ABF stands for Angle Based Flattening. ABF can give a bit better result than LSCM when unwrapping organic shapes.
Unwrap ConformalUnwrap Conformal unwraps the selected geometry with the method LSCM, which is the short for Least Square Conformal Mapping. LSCM can give a bit better results than ABF with geometric shapes.

Last Operator Unwrap

Method

Method is a drop down box where you can choose the unwrap method.

Method Angle based + Conformal
Method Angle based + Conformal
Method Angle based + Conformal

Unwrap ABF and Unwrap LSCM shares the same Last Operator.

Method

Method is a drop down box where you can choose between Unwrap method Angle Based and Conformal.

Fill Holes

Fill Holes

Fill holes in the mesh before unwrapping.

EntryWhat it does
Use Subdivision SurfaceUnwraps an existing Subdivision Modifier. You need to add a Subdivision Modifier first.
Correct AspectTake the Image Aspect Ratio into account.

Margin Method

Margin Method
EntryWhat it does
ScaledUse the scale of existing UV to multiply margin.
AddJust add the margin and ignore any existing UV.
FractionSpecify a precise fraction of specific UV.

Margin

The distance between the single UV patches.

Method Minimum Stretch
Method Minimum Stretch
Iterations

Number of iterations.

EntryWhat it does
No FlipPrevent flipping UV's
Importance WeightTake per vertex importance weights into account.
Use Subdivision SurfaceUnwraps an existing Subdivision Modifier. You need to add a Subdivision Modifier first.
Correct AspectTake the Image Aspect Ratio into account.

Margin Method

Margin Method
EntryWhat it does
ScaledUse the scale of existing UV to multiply margin.
AddJust add the margin and ignore any existing UV.
FractionSpecify a precise fraction of specific UV.

Margin

The distance between the single UV patches.

Smart UV Project

Smart UV Project

Smart UV Project projects the UV mapping from different angles.

Smart UV Project Settings dialogue

Angle Limit

The Angle Limit defines after which angle the mapping happens from the next side. With an angle of 66 you have around six sides to map from. The calculation is 360/66.

Margin Method
Margin Method
EntryWhat it does
ScaledUse the scale of existing UV to multiply margin.
AddJust add the margin and ignore any existing UV.
FractionSpecify a precise fraction of specific UV.
Rotation Method
Rotation Method

How to rotate islands.

EntryWhat it does
Island MarginIsland Margin defines the distance between the UV patches.
Area WeightWeight Projection Vector by faces with larger areas.
Correct AspectTake the Image Aspect Ratio into account.

Last Operator Smart UV Project

Last Operator Smart UV Project
Last Operator Smart UV Project

The Last Operator for Smart UV Project contains the same settings than the Smart UV Project Settings dialogue.

Lightmap Pack

Lightmap Pack

Lightmap Pack maps each face individually, and puts the result into the UV space. Without margin.

Lightmap Pack has no Last Operator.

Settings

EntryWhat it does
SelectionSelection is a drop-down box where you can choose what will be packed, either Selected Faces or All Faces.
Share Tex SpaceMap all objects into one lightmap.
New UV MapCreate a new UV map for every new mesh.
Pack QualityThe pack quality.
MarginThe distance between the single UV patches.

Follow Active Quads

Follow Active quads maps UV coordinates starting from an active face, and maps all adjacent faces in quad shape then. This way you can for example unwrap a pipe or a road. You first need to have a face selected. Then select everything. And then click at Follow Active Quads.

Settings
Settings
Edge Length Mode

Edge Length Mode is a drop-down box where you can choose the Length method.

Last Operator Follow Active Quads
Last Operator Follow Active Quads
Last Operator Follow Active Quads

The Last Operator contains the same settings than the Settings dialogue.

Cube Projection

Cube Projection maps the mesh from six sides, means cubic.

Last Operator Cube Projection
Last Operator Cube Projection
Last Operator Cube Projection
EntryWhat it does
Cube SizeCube Size defines the size of the UV mesh in the UV space.
Correct AspectTake Image Aspect ratio into account.
Clip to BoundsClip UV Coordinates to bounds after unwrapping.
Scale to BoundsScale UV Coordinates to bounds after unwrapping.

Cylinder Projection

Cylinder Projection tries to map the geometry cylindric.

Last Operator Cylinder Projection
Last Operator Cylinder Projection
Last Operator Cylinder Projection
Direction
Direction

Direction is a drop-down box where you can choose in which direction the spherical projection will be mapped.

Align
Align

Align is a drop-down box where you can choose the Align method.

Pole
Pole

How to handle the faces at the poles.

EntryWhat it does
Preserve SeamsKeep existing seams intact.
RadiusRadius defines the Polar size of the UV mesh in the UV space.
Correct AspectTake Image Aspect ratio into account.
Clip to BoundsClip UV Coordinates to bounds after unwrapping.
Scale to BoundsScale UV Coordinates to bounds after unwrapping.

Sphere Projection

Sphere Projection tries to map the geometry spherical.

Last Operator Sphere Projection
Last Operator Sphere Projection
Last Operator Sphere Projection
Direction
Direction

Direction is a drop-down box where you can choose in which direction the spherical projection will be mapped.

Align
Align

Align is a drop-down box where you can choose the Align method.

Pole
Pole

How to handle the faces at the poles.

EntryWhat it does
Preserve SeamsKeep existing seams intact.
Correct AspectTake Image Aspect ratio into account.
Clip to BoundsClip UV Coordinates to bounds after unwrapping.
Scale to BoundsScale UV Coordinates to bounds after unwrapping.

Project from View

Project from View projects the UV from the current 3D view.

Last Operator Project from View
Last Operator Project from View
Last Operator Project from View
EntryWhat it does
OrthographicUser orthographic projection.
Camera BoundsMap UV's to the camera region taking resolution and aspect into account.
Correct AspectTake Image Aspect ratio into account.
Clip to BoundsClip UV Coordinates to bounds after unwrapping.
Scale to BoundsScale UV Coordinates to bounds after unwrapping.

Project from View (Bounds)

Project from View projects the UV from the current 3D view.

Same as Project from View, but with Scale to Bounds ticked in the Last operator. And so it scales to the bounds.

Mark Seam

Mark Seam

The unwrap algorithms Angle based and Conformal requires to have edges marked as seams. Think of it as a cutting pattern for a trouser for example. Such a trouser is also made of fabric patterns.

Same goes for the UV patches when you use Angle based or conformal unwrapping. You need to cut your mesh into parts and mark edges as seams, so that the algorithm knows where the seams are.

Mark seam marks the currently selected edge(s) as a seam. Seam edges will be displayed as red in the 3D viewport.

EntryWhat it does
Clear SeamClear seam removes the seam from the currently selected edge(s).
ResetResets the UV Projection.

Triangulate Faces

Triangulate Faces

Triangulate Faces triangulates the faces of the selected geometry.

Last Operator Triangulate Faces

Quad Method
Quad Method

Choose how quads should be triangulated.

Shortest diagonal

Splits the quads based on their distance between vertices.

Fixed Alternate
Fixed Alternate

Splits the quads on the second and fourth vertice.

EntryWhat it does
FixedSplits the quads on the first and third vertice.
BeautyTries to optimize the triangulation.
Polygon Method
Polygon Method

Choose how N-Gons should be triangulated.

EntryWhat it does
ClipSplits the polygons with an ear clipping algorithm.
BeautyTries to optimize the triangulation.

Triangles to Quads

Triangles to Quads

Tris to quads tries to convert triangulated geometry back to a quad geometry by removing the edges inside of the quads.

Last Operator Tris to Quads

Max Face Angle
Max Face Angle

Adjust the threshold to adjacent triangles.

EntryWhat it does
Max Shape AngleAdjust the shape angle limit.
Topology influenceHow much to priorize regular grids of qads as well as quads that touch existing quads.
Compare UV'sTakes the UV patches for the calculation into account. Border geometry will not be calculated.
Compare Color attributesTakes the Vertex colors for the calculation into account. Border geometry will not be calculated.
Compare SeamTakes the Vertex colors for the calculation into account. Border geometry will not be calculated.
Compare SharpTakes the as sharp marked edges for the calculation into account. Border geometry will not be calculated.
Compare MaterialsTakes the Materials colors for the calculation into account. Border geometry will not be calculated.
Deselect JoinedOnly select remaining triangles that were not merged.

Shade Smooth

Sets the shading for the object to smooth. Flat means that every face of the object shows facettet, with a sharp edge. Smooth means that the edges are not longer to see.

Shade Smooth
Shade Smooth

Shade Flat

Sets the shading for the object to flat. Flat means that every face of the object shows facettet, with a sharp edge. Smooth means that the edges are not longer to see.

Shade Flat
Shade Flat

Un-Subdivide

Un-Subdivide

Decimates the geometry by trying to make one quad out of four quads. But can also end in Tris where this is not possible.

Last Operator Un-Subdivide

Iterations
Iterations

Number of iterations. This means how deep the calculation should go. One level of SDS, two levels, three levels, etc. . Down to the point where you cannot decimate any geometry anymore.

Split

Splits the edges between the selected vertices. It creates two edges out of one. And splits the edge by that.

Separate submenu

Separate submenu

Separate separates the selected geometry, and creates a new object. The geometry becomes uneditable, since it is now a new object. You will have to leave the Edit mode, select the new object, and re-enter Edit mode when you want to edit it.

EntryWhat it does
SelectionSelection separates the current selection.
By MaterialBy Material separates all geometry that has the same material than the current selection.
By Loose PartsBy Loose parts separates all geometry that is connected by edges to the current selection.

Dissolve Faces

Dissolves the selected faces, which unions the involved faces to one.

Last Operator Dissolve Vertices

Last Operator Dissolve Vertices
Last Operator Dissolve Vertices
Dissolve Vertices

Dissolve remaining vertices.

Delete Faces

Deletes the selected faces.

Show/Hide

Show/Hide

Sub-menu with shows or hide selection, unselected or hidden operators.

Show Hidden

Makes all geometry in the scene visible again.

Hide Selected

Hides the selected geometry.

Last Operator Hide Selected
Last Operator Hide Selected
Last Operator Hide Selected
Unselected

Hides the not selected geometry.

Hide Unselected

Hides the not selected geometry. The selected geometry stays visible.

Vertex Context Menu

Vertex Context Menu

Vertex Context Menu
Vertex Context Menu
Vertex Context Menu

Call this menu with double right click in the 3D viewport. You need to be in Edit mode with a Mesh object. And in selection mode Vertice to see all its content.

Select geometry to reveal all content.

Subdivide

Subdivide
Subdivide

Subdivide divides the selected edges. It subdivides the involved faces too, and can create new vertices.

A more unknown functionality is that it can also randomize the result with the Fractal slider in the Last operator panel.

Last Operator Subdivide

Last Operator Subdivide
Number of Cuts

The number of cuts defines the amount of subdivisions.

Smoothness
Smoothness

This value defines how smooth the subdivision result is. From flat to bent.

Create N-Gons

Create N-Gons if required. Else subdividing N-Gons creates Tris.

Quad Corner Type
Quad Corner Type

Adjust the corner type.

EntryWhat it does
FractalRandomize the selected vertices.
Along NormalWhen randomized, this value defines how strong the subdivision follows the normals of the initial vertices.
Random SeedRandomizing value for fractal randomizing.

Extrude Vertices

Extrudes out the selected vertices by moving the mouse.

Last Operator Extrude Only Vertices and Move

Last Operator Extrude Only Vertices and Move
Last Operator Extrude Only Vertices and Move
Move X Y Z

The coordinates for the extruded geometry.

Orientation
Orientation

Choose the type of orientation, in which coordinate system the action should happen.

Mirror Editing

Enable mirror editing.

Proportional editing
Proportional editing

Enables proportional editing. Activating proportional editing reveals further settings.

EntryWhat it does
Proportional FalloffAdjust the falloff methods.
Proportional SizeSee and adjust the falloff radius.
ConnectedThe proportional falloff gets calculated for connected parts only.
Projected(2D)The proportional falloff gets calculated in the screen space. Depth doesn't play a role. When it's in the radius, then it gets calculated.

Bevel Vertices

Bevel Vertices

Adds a bevel at the selected vertices.

Last Operator Bevel

Last Operator Bevel
Affect

Affect vertices or edges.

Width Type
Width Type

The width type.

EntryWhat it does
WidthThe bevel amount.
SegmentsHow many segments gets created.
Profile ShapeControls the Profile shape. 0.5 means round.
Material IndexAssigns a material slot to the new bevel faces. -1 is the surrounding material.
Harden Normals

When enabled, the per-vertex face normals of the bevel faces are adjusted to match the surrounding faces, and the normals of the surrounding faces are not affected. This will keep the surrounding faces flat (if they were before), with the bevel faces shading smoothly into them. For this effect to work, custom split normals need to be enabled, which requires Auto Smooth to be enabled (see Normals). As a convenience, that option will be enabled for you if it is not already when you enable Harden Normals here.

EntryWhat it does
Clamp OverlapDo not allow beveled geometry to overlap each other. Prevents bevel geometry from intersecting itself. Helps avoid messy geometry in tight corners.
Loop SlideSlides new edges along adjacent geometry for better topology flow
MarkSeams: Mark the edges of the new created geometry as seams. · Sharp: Mark the edges of the new created geometry sharp.
Miter Type
Miter Type
Miter Outer

How the outer miter is set. Miter is how the bevel rounding at a corner is done.

Sharp

Sharp

Creates a sharp miter.

Patch

Patch

This replaces the outside vertex of a miter with 3 vertices. And uses a patch pattern there.

Arc

Arc

This replaces the vertex of a miter with 2 vertices, joined by an arc. A separate Spread parameter says how far to move the vertices away from their original position.

Inner Miter
Inner Miter

How the inner miter is set. Miter is how the bevel rounding at a corner is done.

Sharp

Sharp

Creates a sharp miter.

Arc

Arc

This replaces the vertex of a miter with 2 vertices, joined by an arc. A separate Spread parameter says how far to move the vertices away from their original position.

Spread

Spread

Belongs to inner miter method Arc. Adjust how strong the inner radius is bent.

Intersection type
Intersection type

The method to use to create meshes at intersections. Bevel can create self intersecting geometry.

EntryWhat it does
Grid FillFills intersections with a grid-like topology.
CutoffTrims or removes overlapping geometry at intersections
Face Strength
Face Strength

Set Face Strength on the faces involved in the bevel, according to the specified mode. This can be used in conjunction with a Weight Normals Modifier (with the Face Influence option checked).

EntryWhat it does
NoneDo not set face strength.
NewSet the face strength of new faces along edges to Medium, and the face strength of new faces at vertices to Weak.
AffectedIn addition to those set for the New case, also set the faces adjacent to new faces to have strength Strong.
AllIn addition to those set for the Affected option, also set all the rest of the faces of the model to have strength Strong.
Profile Type
Profile Type

The profile type.

Superellipse

Uses a mathematically smooth curve for bevel profiles

Custom

Allows manual control of the bevel profile shape via a curve widget.

Presets

Presets

Curve presets.

Navigation elements

EntryWhat it does
Zoom in and outThe two buttons with the magnifying glass at it zooms in and out in the curve window.
Reverse PathReverses the curve path.
Toggle Profile ClippingTurns the profile clipping on or off.

Tools menu

Tools menu
EntryWhat it does
Reset ViewResets the curve windows zoom.
Reset CurveResets the curve to the initial shape.
Curve view
Curve view

Adjust the profile curve.

Left click where no point is adds a new point. Left click at a point allows you to move it.

Holding down Shift while moving a node point activates precision movement.

Holding down ctrl while moving activates temporary snapping.

When a point is selected then the curve view reveals a sub menu at the bottom.

Handler and node position

Handler and node position
Handler and node position

When you select a node, then the handler and node position tools shows below the curve window.

EntryWhat it does
Handle Type Auto HandleSets the handle type of this curve point to smooth.
Handle Type Vector HandleSets the handle type of this curve point to sharp.
Handle Type Free HandleSets the handle type of this curve to Free handles. The curve point has now two handles with which you can adjust the curve before and after the point each.
Handle Type Aligned Free HandleSets the handle type of this curve to Free handles. The curve point has now a handle with which you can adjust the curve.
X Y ValuesThe position of the currently selected curve point
EntryWhat it does
Sample straigt edgesSample edges with vector handles.
Sample even lengthSample edges with even lengths.

Make Edge/Face

Adds a face when you have edges selected. And Edges when you have Vertices selected. It's a Bridge tool.

You can have either the one method or the other. When you select two adjacent vertices, then you select the edge too. And the tool works in edge mode then. In this case just the possible faces gets created. Not edges between single vertices.

First select the edges or Vertices that you want to bridge. Then click the New Edge/Face from Vertices Button.

Make Edge/Face
Make Edge/Face
Make Edge/Face
Make Edge/Face

Connect Vertex Path

Connect Vertex Path

Connect Vertex path connects selected vertices, but takes the vertex order into account in which you selected the vertices. It just creates edges between vertices that are not connected in this order.

Connect Vertex Pair

Connect Vertex Pair

Connect Vertex pair connects selected vertices and makes a face of the pairs.

Push/Pull

It pushes or pulls the object positions relative to the center of the selection.

In Object mode this tool requires to have more than one object selected.

Last Operator Push/Pull

Last Operator Push/Pull
EntryWhat it does
DistanceAdjust the strength of influence of the tool.
Mirror EditingEnable mirror editing.
Proportional editing
Proportional editing

Enables proportional editing. Activating proportional editing reveals further settings.

EntryWhat it does
Proportional FalloffAdjust the falloff methods.
Proportional SizeSee and adjust the falloff radius.
ConnectedThe proportional falloff gets calculated for connected parts only.
Projected(2D)The proportional falloff gets calculated in the screen space. Depth doesn't play a role. When it's in the radius, then it gets calculated.

Shrink/Fatten

Shrink/Fatten scales the selected geometry along its normals. Transform orientation and Pivot point gets ignored.

A positive value pushes the vertices outwards. A negative value pushes the vertices inwards.

Last Operator Shrink/Fatten

Last Operator Shrink/Fatten

The Last Operator Shrink/Fatten panel gives you tools to adjust the Shrink/Fatten operation. Here you have numeric input for the strength and a few more options.

EntryWhat it does
OffsetOffset is the strength of the offset for Shrink/Fatten.
Offset EvenOffset Even scales the selection to give more thickness in even areas.
Mirror EditingEnable mirror editing.
Proportional editing
Proportional editing

Enables proportional editing. Activating proportional editing reveals further settings.

EntryWhat it does
Proportional FalloffAdjust the falloff methods.
Proportional SizeSee and adjust the falloff radius.
ConnectedThe proportional falloff gets calculated for connected parts only.
Projected(2D)The proportional falloff gets calculated in the screen space. Depth doesn't play a role. When it's in the radius, then it gets calculated.

Shear

Shear shears the selection.

Last Operator Shear

Last Operator Shear

The shear tool works along a imaginary 2d plane. The shear axis controls if the items are sheared along the x or the y axes of this plane. This is the plane along which the transformation happens. You can shear along the x or the y axis of this plane.

To make things even more complicated, the orientation of this imaginary plane is defined by the Axis and Axis Ortho items below.

EntryWhat it does
OffsetAdjust an offset.
AxisDefines one axis of the imaginary shear axis plane.
Axis Ortho
Axis Ortho

Defines the other axis of the imaginary shear axis plane.

EntryWhat it does
OrientationChoose the orientation for the shear action.
Mirror EditingEnable mirror editing.
Proportional editingEnables proportional editing. Activating proportional editing reveals further settings. · Proportional Falloff: Adjust the falloff methods. · Proportional Size: See and adjust the falloff radius. · Connected: The proportional falloff gets calculated for connected parts only. · Projected(2D): The proportional falloff gets calculated in the screen space. Depth doesn't play a role. When it's in the radius, then it gets calculated.

Randomize Vertices

This tool allows randomizes the positions of the selected vertices.

Last Operator Randomize

Last Operator Randomize
EntryWhat it does
AmountAdjust the amount.
UniformThe uniform offset distance.
NormalAlign the offset direction to the normals.
Random SeedThe seed value for randomization.

Smooth Laplacian

Laplacian Smooth Vertex smooths out the angles between the selected vertices. It is a tool to reduce noise at the mesh. It works a bit different than the normal Smooth Vertex tool. And gives a different result. The Laplacian method allows you to preserve the volume, and to adjust border smoothing.

Last Operator Laplacian Smooth Vertices

Last Operator Laplacian Smooth Vertices
Last Operator Laplacian Smooth Vertices
EntryWhat it does
Number of IterationsNumber of Iterations is the number of iterations that the smoothing action gets repeated. With 1 the smoothing is just performed once. With 10 it is performed ten times.
Lambda FactorLambda Factor is the strength of the smoothing.
Lambda Factor in borderLambda Factor is the strength of the smoothing in border areas.
Smooth AxisThe Smooth Axis check boxes allows you to limit the smoothing to specific world axis.
Preserve VolumePreserve Volume preserves the volume of the object.

Snap Vertices

Snap Vertices

Choose several methods to snap one element to another. The menu items should be self explaining.

Last Operator Snap

Last Operator Snap

Some snap operations shows a last operation panel, some not.

EntryWhat it does
OffsetIf the selection should snap as a whole, or if each individual element of the selection should snap.
RotationRotate to match the cursor.

Mirror Vertices

Mirror by hotkeys. You activate the tool, type in x for x global for example, or x x for x local. And the selection gets mirrored.

Last Operator Mirror

Last Operator Mirror

The Last Operator Mirror panel gives you tools to adjust the mirror action.

Orientation
Orientation

Orientation is a drop-down box choose the type of orientation for the mirroring action.

Constraint Axis

Constraint Axis gives you again the possibility to define the mirror axis. You can choose more than one axis here.

Vertex Crease

Vertex Crease

When you use a Subdivision Surface Modifier, then you can define the sharpness of selected vertices with this tool. Crease vertices will be marked colored in edit mode.

You will see a value in the header that indicates the current strength when you activate the tool. Move with the mouse to increase or decrease the value. Or type in a value while you are in this mode. You can also scale into negative range.

Vertex Crease

A negative crease value will subtract from the current active crease value in case it exists already from a former crease operation. A Crease value of -1 removes the crease from this edge.

Last Operator Vertex Crease

Last Operator Vertex Crease
Last Operator Vertex Crease
Factor

Adjust the crease factor.

Merge Vertices

Merge Vertices

Merges the geometry.

At Center, At Cursor, Collapse

Merges the geometry with the given methods.

Last Operator Merge

Last Operator Merge
EntryWhat it does
TypeChoose the merge method again.
UV'sMove the UV's according to the merge.

By Distance

Merge the vertices by their distance to each other. This tool is meant to remove double vertices at the same location.

Last Operator Merge by Distance

Last Operator Merge by Distance
Last Operator Merge by Distance
EntryWhat it does
Merge DistanceAdjust the distance below which the vertices gets merged. Merge selected vertices to unselected vertices.
UnselectedMerge also unselected vertices
Sharp EdgesCalculate sharp edges if possible.

Split

Splits the edges between the selected vertices. It creates two edges out of one. And splits the edge by that.

Separate

Separate

Separate separates the selected geometry, and creates a new object. The geometry becomes uneditable, since it is now a new object. You will have to leave the Edit mode, select the new object, and re-enter Edit mode when you want to edit it.

EntryWhat it does
SelectionSelection separates the current selection.
By MaterialBy Material separates all geometry that has the same material than the current selection.
By Loose PartsBy Loose parts separates all geometry that is connected by edges to the current selection.

Dissolve Vertices

Dissolve Vertices dissolves the selected Vertices.

Note that pressing Del in Vertice select mode calls Dissolve Vertices already. It's the same operator. But you don't get the Last operator that way.

Last Operator Dissolve Vertices

Last Operator Dissolve Vertices
Last Operator Dissolve Vertices
EntryWhat it does
Face SplitSplit off Face corners to maintain surrounding geometry
Tear BoundarySplit off Face corners instead of merging faces.

Delete Vertices

Deletes the selected vertices.

Delete Vertices

The Show/Hide menu is available for all object types and in all modes. It is usually in the object related menu to find. In Object mode it's the Object menu, for a curve object in edit mode it is the Curve menu. It always contains three menu items. Show Hidden, Hide Selected and Hide Unselected.

EntryWhat it does
Show HiddenMakes all hidden elements in the scene visible again.
Hide SelectedHides the selected elements.

Hide Unselected

Hides the not selected elements. The selected elements stays visible.

Last Operator Reveal Hidden / Hide Selected

Last Operator Reveal Hidden / Hide Selected
Last Operator Reveal Hidden / Hide Selected
Select

Define if the selected or the unselected elements gets hidden or revealed.