View & accessibility
Thumbnails
Motion
Bforartists
5.1
Editors

Draw Mode

Draw strokes with the grease pencil: menus, brushes, layers and settings of Draw Mode.

37
 min read
Up to date for 
5.1
draft

Grease Pencil › Draw Mode: every menu, tool, sidebar tab and context menu of this mode, on one page. Use the panels on the right to jump between the regions.

Header

Draw menu

Draw Mode - Draw Menu

Draw Mode - Draw Menu
Draw Mode - Draw Menu

Active Layer

Active Layer

Set and show the active grease pencil layer. The layer with the pencil is the active layer for drawing.

New Layer

Add a new draw layer.

Animation

Animation
Insert Blank Keyframe ( Active Layer )

Inserts a keyframe into the active layer.

Insert Blank Keyframe ( All Layers )

Inserts a keyframe into all layers.

Last Operator Insert Blank Frame
Last Operator Insert Blank Frame
Last Operator Insert Blank Frame

Some snap operations shows a last operation panel, some not.

EntryWhat it does
All LayersInsert into active layer or into all layers.
DurationThe frame duration.*

Interpolate Sequence

Interpolate strokes between the previous and next keyframe by adding multiple keyframes. When you are on a frame between two keyframes and click the sequence button, then a breakdown keyframe will be added on every frame between the previous and next keyframe.

Show/Hide

Show/Hide
EntryWhat it does
Show all LayersMakes all layers in the scene visible .
Hide Active LayerHides the active layer.
Hide inactive Layers

Hides the not selected layers. The selected layers stays visible.

Last Operator Hide Layers
Last Operator Hide Layers
Last Operator Hide Layers
Unselected

Hides the not selected layers.

Clean Up

Clean Up
Clean Loose Points

Deletes not connected stroke geometry that is made of loose points.

Last Operator Clean Loose Points
Last Operator Clean Loose Points
Last Operator Clean Loose Points
Limit

The number of vertices below which a stroke gets counted as a loose point.

Delete Duplicated Frames

Deletes all duplicated frames.

Last Operator Clean Duplicated Frames
Last Operator Clean Duplicated Frames
Last Operator Clean Duplicated Frames
Type
Type

Delete just in the selected frames or in all frames.

Reproject Strokes

Re project the selected strokes onto a new plane from the current viewport. So that all strokes are on one plane.

Re project Strokes menu
Re project Strokes menu
Re project Strokes menu

Using this tool opens a popup menu. Choose the projection type method.

Last Operator Re project Strokes
Last Operator Re project Strokes
Last Operator Re project Strokes
EntryWhat it does
Projection TypeA popup menu. Choose the reprojection Strokes type method again.
Keep OriginalKeep the original stroke and create a copy before reprojecting.
Remove Fill Guides

In Draw mode with the fill tool you are able to draw so called fill guide with holding down the Alt key. They act as the boundary of the fill area. This tool removes these fill guides.

Last Operator Remove Fill Guides
Last Operator Remove Fill Guides
Last Operator Remove Fill Guides
Mode
Mode

All frames or just the current frame.

Sample Color

Samples the color under the mouse

Tool Shelf

Tools

Tool Shelf - Grease Pencil - Draw Mode

Tool Shelf - Grease Pencil - Draw Mode
Tool Shelf - Grease Pencil - Draw Mode

In Sculpt Mode you will mainly find draw tools in the tool shelf.

The brushes settings are covered in the chapter 7.3.12 Editors - 3D View - Sidebar - Tool Tab - Grease Pencil - Draw Mode

For the Annotate tools group see chapter 7.2.1 Editors - 3D View - Tool Shelf - Object Mode

3D Cursor Tool

The 3D cursor tool is explained in the chapter 7.2.1 Editors - 3D View - Tool Shelf - Object Mode. We won't cover this tool again here.

Footer

Some of the brushes and tools shows some further information in the footer.

Hotkeys

Some tools have some additional hotkey functionality. We will cover it one by one.

Brush

Brush

The Brush tool allows you to draw free-hand strokes. You paint with the left mouse. There are various brushes available.

Holding down Shift while drawing reveals a stabilizer widget which gives you more fine control over painting the stroke.

Brush

Holding down Alt while drawing ill allow you to draw straight horizontal or vertical lines.

Holding down Ctrl while drawing will turn the brush into an eraser brush.

Pressing B will allow you to box select stroke parts and delete them.

Draw Color
Draw Color
Draw Color

The Draw color is in real a material. To change the color you need to change the material. Or create one with the color that you need. The Grease Pencil Stroke object comes already with a few predefined colors. You can choose between them in the header tools area.

New materials can be created in the Properties editor in the Materials tab. You can also change the color of an existing material. But note that all previously drawn strokes will also change their color then. It is one material for one color.

Erase

Erase
Erase

Erase stroke curve points under the mouse.

Fill

Fill

This tool does not fill, but extend strokes of closed strokes areas by click drag, coming from the border. For example, when you create a Bezier circle. When you then click in the inner area, drag the mouse and release it, then the outer line of this Bezier circle gets extended into the inner direction by the in the brush panel adjusted amount.

When you use this tool outside of closed geometry, then it draws a frame around the current view.

Shapes

Shapes

Allows to draw shapes like box and lines.

Box
Box

Draw rectangular shapes by click drag. Hold Shift to create square shapes. The handlers allows you to adjust the rectangle to your needs. Right mouse abandons the action. Pressing enter or middle mouse button confirms and makes the stroke real.

Circle
Circle

Draw oval shapes by click drag. Hold Shift to create square shapes. The handlers allows you to adjust the rectangle to your needs. Right mouse abandons the action. Pressing enter or middle mouse button confirms and makes the stroke real.

Line
Line

Draw straight lines by click drag. The yellow points are handlers that can be dragged around. Right mouse abandons the action. Pressing enter or middle mouse button confirms and makes the stroke real.

Hotkey E allows you to extrude the line.

Poly line
Poly line

Draw straight lines by click drag. Clicking creates a new line in the polygon. Right mouse abandons the action. Pressing enter or middle mouse button confirms and makes the stroke real.

The polygon cannot be closed.

Arc
Arc

Draw simple arcs by click drag. The yellow points are handlers that can be dragged around. Right mouse abandons the action. Pressing enter or middle mouse button confirms and makes the stroke real.

Curve
Curve

Draw complex Bezier style curves by click drag. First you create a straight line. The handlers allows you to deform the curve to your needs. Right mouse abandons the action. Pressing enter or middle mouse button confirms and makes the stroke real.

Trim

Trim

Lasso select delete tool. Erases stroke curve points in the selection.

Tool settings
Tool settings
EntryWhat it does
Active LayerOnly edit the active layer of the object.
Keep CapsDefine if after cutting the stroke the cap of the cut side will be set as flat or keep them as they are.
Adjust last operator Grease Pencil Trim
Adjust last operator Grease Pencil Trim
Adjust last operator Grease Pencil Trim
EntryWhat it does
Stabilize StrokeSelection lags behind mouse, and follows a smoother path
Smooth Stroke FactorAdjust the smoothness by a factor. Higher values gives smoother strokes.
Smooth Stroke RadiusMinimum distance from last point before selection continues.

Eye Dropper

Eye Dropper

Pick a grease pencil material and make it the draw color. Dependant of the mode the picked color gets added to the material list. Or the palette. Which both shows when you are in the brush tool. Palette is in the sidebar then. Or is directly applied to the paint brush.

Eye Dropper
Tool settings
Tool settings
Material mode
Material mode
Material mode

Pick the stroke color, the Fill color, or both.

Palette mode
Palette mode

Add the color to a color palette.

Palette browser
Palette browser

The button at the left opens a drop down list to choose between your palettes.

EntryWhat it does
Edit BoxRead the name of the currently active palette. You can also rename the palette here. A click into the edit box makes the name editable.
Number of usersSee how many users the palette currently has.
Fake UserFake User sets the element to have a fake user. Zero user data-blocks are normally not saved. But sometimes you want to force the data to be kept even when the data block has no user.
Add paletteAdd a new palette.
Remove PaletteClicking at this button removes the palette. Note that you need to save, close Bforartists and reload the blend file to remove the palette completely.
New Palette colorAdjust a color in the color picker. Then click at the add button to add this color to the palette.
Delete Palette colorSelect the color in the palette, then click at the minus button to remove it.
Move Palette Color up and downWith these two buttons you can move the active color up or down in the palette.
Sort By
Sort By

Sort the palette by different methods.

Palette Colors
Palette Colors

The actual list of the current palette colors. Click at one to make it the active one that gets used for painting.

Brush mode
Brush mode

The picked color gets directly applied to the active brush.

Interpolate

Interpolate grease prencil strokes between frames. You need to have two frames to interpolate between.

Tool settings
Tool settings
Layer
Layer

What layers to include in the interpolation.

Flip Mode
Flip Mode

How to invert destination stroke to match start and end with source stroke.

EntryWhat it does
SmoothAmount of smoothing to apply to interpolated strokes, to reduce jitter or noise.
IterationsHow often to smooth newly created strokes.
Excclude BreakdownsExclude existing breakdown keyframes as interpolation extremes.

Sidebar

Draw Mode

Draw Mode

Draw Mode

Just the grease Pencil object has a Draw mode.

The Grease Pencil Object allows you to draw in 2D in the workspace.

It starts as an object type. By switching into paint mode it becomes a paint feature. And editing turns it into a curve or a mesh object then.

In the Tools tab you will find all the options and settings for drawing and manipulating the grease pencil object, means your drawing.

The type Blank allows you to draw strokes.

The type Stroke allows you to draw filled forms.

The type Monkey is just an example object.

Draw Mode
Draw Mode
Draw Mode

Brush Asset Panel

Brush Asset Panel

The Brush Asset Panel contains the different Brushes and some Brush settings. Choose and adjust your current active brush.

Browse Brush

The big image at the top is a dropdown box that allows you to choose a brush. Click at it, and you will see the different brushes. A click at one of the images will choose this brush then.

Browse Brush

Brushes are assets. You can load them from different libraries if you want.

Brush Specials menu

Brush Specials menu

This menu becomes active when you create a new brush. Which can be done wiht the Plus button in the name property. This data cannot be changed for builtin system brushes.

Edit Metadata
Edit Metadata

Calls a popup where you can adjust further informations and settings for the brush.

EntryWhat it does
CatalogThe asset catalog in which the brush is stored.
AuthorThe brush author.
DesctriptionAdd a description
OK / CancelAccept or decline the changes.
Edit Preview ImageAllows you to load a custom preview image.
EntryWhat it does
Save Brush AssetThis button is just active with a custom brush. It saves all changes made at the brush settings into the current custom brush.
Revert Brush AssetReverts the brush settings to the default values of the brush in the asset library.
Name
Name

The edit box below the Image shows the name of the current active brush.

The + button allows you to add a new pencil with the current settings. Note that the brushes are NOT automatically saved when you close Bforartists. You need to save the brush asset. See above.

The X button deletes the brush from the brushes list and from the asset library. This button is just active with a custom brush. You will be prompted by a warning so that you don't accidentally remove the brush.

Name

Brush Settings Panel

Brush Settings Panel

Header - Add Brush Preset

Header - Add Brush Preset
Header - Add Brush Preset

In the header is a brush preset menu where you can store and load custom brush presets. The dialog should be self explaining. In the edit box you type in the name of your new preset. And with clicking at the + button the new preset gets stored. Existing presets can be removed by clicking at the - button at the right side of the preset.

Material Browser

Material Browser
Material Browser

This browser is just active when the Keep material assigned to Brush Pin is activated.

The colors for the grease pencil are materials each. For the grease pencil type Blank you will just have one color available. For this type you have to create new materials in the material tab first when you need more colors. But the other two types, strokes and monkey, comes with a few base materials already. Which can be found in the Materials tab.

Material Browser

The tool settings above the header shows this panel too. And here you can quickly change the color of a material. It is explained in the chapter Materials Tab.

Drop down box

Choose another material to draw with.

Brush Settings Panel - Draw brushes

Brush Settings Panel - Draw brushes
Brush Settings Panel - Draw brushes

Airbrush, Ink Pen, Ink Pen Rough, Marker Bold, Marker Chisel, Pen, Pencil, Pencil Soft and Tint.

Brush Settings Panel - Draw brushes
Brush Settings Panel - Draw brushes

Note that not all draw brushes have curve settings for radius and strength.

Size

The size edit box allows you to adjust the size of the brush.

Use unified size

The size is shared across the brushes.

Use Pressure

The button behind the edit box enables tablet pressure sensitivity for radius.

Pressure Size Curve
Pressure Size Curve

Behind the pressure size button there is a button to reveal the size pressure curve panel. When you activate Size Pressure for tablets, then the Size Pressure curve becomes active, and can be adjusted.

The pressure size curve allows you to adjust the falloff curve for the tablet pressure. It shows when Use Pressure is activated. The curve panel shows when clicking at the button.

Selecting Points
Selecting Points

You can select curve points. This reveals two edit boxes for the x and y coordinate of this point.

Selected points can be moved around. Left click at them, hold the mouse button down and move them to a new location.

Adding Points
Adding Points

You can add new curve points by simply left clicking at the curve. Move the mouse to position them where you need it.

Navigation elements
EntryWhat it does
Zoom inZooms in.
Zoom outZooms out.

Clipping options

Clipping options

Set up clipping for the stroke.

Tools

Tools

Tools is a menu where you can find some curve related tools.

EntryWhat it does
Reset ViewResets the curve windows zoom.
Reset CurveResets the curve to the initial shape.

Handles

Handles

You can choose between Auto handle, Vector Handle and Auto Clamped.

EntryWhat it does
Position X / YThe position of the selectedc curve point.
Delete PointsDeletes the selected curve point.

Curve Presets

Curve Presets

A curve preset to start with.

Strength

Strength

The Strength edit box allows you to adjust the strength of the brush.

Use unified size

The size is shared across the brushes.

Use Pressure

The button behind the edit box enables tablet pressure sensitivity for strength.

Pressure Size Curve
Pressure Size Curve

Behind the pressure size button there is a button to reveal the size pressure curve panel. When you activate Size Pressure for tablets, then the Size Pressure curve becomes active, and can be adjusted.

The pressure size curve allows you to adjust the falloff curve for the tablet pressure. It shows when Use Pressure is activated. The curve panel shows when clicking at the button.

Selecting Points
Selecting Points

You can select curve points. This reveals two edit boxes for the x and y coordinate of this point.

Selected points can be moved around. Left click at them, hold the mouse button down and move them to a new location.

Adding Points
Adding Points

You can add new curve points by simply left clicking at the curve. Move the mouse to position them where you need it.

Navigation elements
EntryWhat it does
Zoom inZooms in.
Zoom outZooms out.

Clipping options

Clipping options

Set up clipping for the stroke.

Tools

Tools

Tools is a menu where you can find some curve related tools.

EntryWhat it does
Reset ViewResets the curve windows zoom.
Reset CurveResets the curve to the initial shape.

Handles

Handles

You can choose between Auto handle, Vector Handle and Auto Clamped.

EntryWhat it does
Position X / YThe position of the selectedc curve point.
Delete PointsDeletes the selected curve point.
Curve Presets
Curve Presets

A curve preset to start with.

Stroke Method

Stroke Method

Controls how Grease Pencil strokes are treated during editing and rendering. Useful for defining whether strokes act as outlines, fills, or both, depending on the drawing workflow

Stroke1
Stroke1

Points are interpreted as line strokes only. Produces visible outlines without fill regions. Best for sketching, inking, or line-based animation.

EntryWhat it does
FillPoints are interpreted as fill regions only. Creates solid shapes without visible outlines. Useful for coloring, shading, or shape-based animation.
BothPoints contribute to both stroke outlines and fill regions. Produces combined line + fill geometry. Ideal for workflows where outlines and fills need to remain linked.

Caps Type

Caps Type

Controls the shape of stroke endpoints (caps). Useful for defining whether strokes end with rounded tips or flat edges, affecting both aesthetics and readability in drawings.

EntryWhat it does
RoundEnds strokes with a smooth, circular cap. Creates softer, organic-looking stroke endings. Ideal for calligraphy, sketching, or expressive linework.
FlatEnds strokes with a straight, cut-off edge. Produces sharp, mechanical-looking stroke endings. Useful for technical drawings, graphic styles, or when clean edges are required.

Brush Settings Panel - Draw brushes - Advanced Sub panel

Airbrush, Ink Pen, Ink Pen Rough, Marker Bold, Marker Chisel, Pen, Pencil, Pencil Soft and Tint.

Brush Settings Panel - Draw brushes - Advanced Sub panel
Brush Settings Panel - Draw brushes - Advanced Sub panel

Radius Unit

Radius Unit

Measure the brush size relative to view or scene.

EntryWhat it does
SpacingSpacing between brush daubs. Calculated as a percentage of brush diameter.
Active SmoothThe amount of smoothing while drawing.
AngleDirection of the stroke at which the brush gives the maximal thickness. 0 degree for horoizontal.
FactorReduction of the brush thickness when stroke is perpendicular to the angle direction. Calculated by a factor.
HardnessThe hardness falloff from the center of dot and box strokes. 1 means a solid stroke.
AspectRead only. And unfortunately also not to modify. The width and height of the alpha gradient, means the brush shape.

Brush Settings Panel - Draw brushes - Stroke Sub panel

Brush Settings Panel - Draw brushes - Stroke Sub panel
Brush Settings Panel - Draw brushes - Stroke Sub panel

Airbrush, Ink Pen, Ink Pen Rough, Marker Bold, Marker Chisel, Pen, Pencil, Pencil Soft and Tint.

Brush Settings Panel - Draw brushes - Stroke Sub panel
Brush Settings Panel - Draw brushes - Stroke Sub panel

Here you will find some further stroke related settings. It has three sub sections. Post Processing, Randomize and Stabilize Stroke.

Post Processing

Post Processing
Post Processing

Here you find some post processing settings for new strokes.

EntryWhat it does
SmoothThe smooth amount to reduce jittering.
IterationsNumber of iterations to smooth new created strokes.
IterationsNumber of iterations to smooth new created strokes.
Subdivision StepsNumber of subdivisions of new created strokes
SimplifySimplify new created strokes.
Trim Stroke EndsTrim intersecting stroke ends.
OutlineConvert stroke to perimeter. This tool requires an active camera in the scene. · Material: Material used for the secondary uses for this brush. · Thickness: The thickness of the outline stroke, relative to the current brush thickness.

Randomize

Randomize

Adds variation to the brush color per stroke or while drawing a stroke.

Radius

Randomize the pressure.

EntryWhat it does
Stroke RandomizationUse randomness per stroke, instead of while drawing a stroke. This will define a new random value when you draw a new stroke.
Use PressureUses the brush pressure to define how random the influence will be. Maximum pressure is maximum randomization.
Pressure Size Curve
Pressure Size Curve

Behind the pressure size button there is a button to reveal the size pressure curve panel. When you activate Size Pressure for tablets, then the Size Pressure curve becomes active, and can be adjusted.

The pressure size curve allows you to adjust the falloff curve for the tablet pressure. It shows when Use Pressure is activated. The curve panel shows when clicking at the button.

Selecting Points
Selecting Points

You can select curve points. This reveals two edit boxes for the x and y coordinate of this point.

Selected points can be moved around. Left click at them, hold the mouse button down and move them to a new location.

Adding Points
Adding Points

You can add new curve points by simply left clicking at the curve. Move the mouse to position them where you need it.

Navigation elements
EntryWhat it does
Zoom inZooms in.
Zoom outZooms out.

Clipping options

Clipping options

Set up clipping for the stroke.

Tools

Tools

Tools is a menu where you can find some curve related tools.

EntryWhat it does
Reset ViewResets the curve windows zoom.
Reset CurveResets the curve to the initial shape.

Handles

Handles

You can choose between Auto handle, Vector Handle and Auto Clamped.

EntryWhat it does
Position X / YThe position of the selectedc curve point.
Delete PointsDeletes the selected curve point.

Curve Presets

Curve Presets

A curve preset to start with.

Strength

Randomize the strength.

EntryWhat it does
Stroke RandomizationUse randomness per stroke, instead of while drawing a stroke. This will define a new random value when you draw a new stroke.
Use PressureUses the brush pressure to define how random the influence will be. Maximum pressure is maximum randomization.
Pressure Size Curve
Pressure Size Curve

Behind the pressure size button there is a button to reveal the size pressure curve panel. When you activate Size Pressure for tablets, then the Size Pressure curve becomes active, and can be adjusted.

The pressure size curve allows you to adjust the falloff curve for the tablet pressure. It shows when Use Pressure is activated. The curve panel shows when clicking at the button.

Selecting Points
Selecting Points

You can select curve points. This reveals two edit boxes for the x and y coordinate of this point.

Selected points can be moved around. Left click at them, hold the mouse button down and move them to a new location.

Adding Points
Adding Points

You can add new curve points by simply left clicking at the curve. Move the mouse to position them where you need it.

Navigation elements
EntryWhat it does
Zoom inZooms in.
Zoom outZooms out.

Clipping options

Clipping options

Set up clipping for the stroke.

Tools

Tools

Tools is a menu where you can find some curve related tools.

EntryWhat it does
Reset ViewResets the curve windows zoom.
Reset CurveResets the curve to the initial shape.

Handles

Handles

You can choose between Auto handle, Vector Handle and Auto Clamped.

EntryWhat it does
Position X / YThe position of the selectedc curve point.
Delete PointsDeletes the selected curve point.

Curve Presets

Curve Presets

A curve preset to start with.

Rotation

Randomize the rotation.

EntryWhat it does
Stroke RandomizationUse randomness per stroke, instead of while drawing a stroke. This will define a new random value when you draw a new stroke.
Use PressureUses the brush pressure to define how random the influence will be. Maximum pressure is maximum randomization.
Pressure Size Curve
Pressure Size Curve

Behind the pressure size button there is a button to reveal the size pressure curve panel. When you activate Size Pressure for tablets, then the Size Pressure curve becomes active, and can be adjusted.

The pressure size curve allows you to adjust the falloff curve for the tablet pressure. It shows when Use Pressure is activated. The curve panel shows when clicking at the button.

Selecting Points
Selecting Points

You can select curve points. This reveals two edit boxes for the x and y coordinate of this point.

Selected points can be moved around. Left click at them, hold the mouse button down and move them to a new location.

Adding Points
Adding Points

You can add new curve points by simply left clicking at the curve. Move the mouse to position them where you need it.

Navigation elements
EntryWhat it does
Zoom inZooms in.
Zoom outZooms out.

Clipping options

Clipping options

Set up clipping for the stroke.

Tools

Tools

Tools is a menu where you can find some curve related tools.

EntryWhat it does
Reset ViewResets the curve windows zoom.
Reset CurveResets the curve to the initial shape.

Handles

Handles

You can choose between Auto handle, Vector Handle and Auto Clamped.

EntryWhat it does
Position X / YThe position of the selectedc curve point.
Delete PointsDeletes the selected curve point.

Curve Presets

Curve Presets

A curve preset to start with.

Hue
Hue

Shifts the base color across the color wheel. You need to be in color attribute mode.

EntryWhat it does
Stroke RandomizationUse randomness per stroke, instead of while drawing a stroke. This will define a new random value when you draw a new stroke.
Use PressureUses the brush pressure to define how random the influence will be. Maximum pressure is maximum randomization.
Saturation

Randomize original saturation. Adjusts the intensity of the color. You need to be in color attribute mode.

EntryWhat it does
Stroke RandomizationUse randomness per stroke, instead of while drawing a stroke. This will define a new random value when you draw a new stroke.
Use PressureUses the brush pressure to define how random the influence will be. Maximum pressure is maximum randomization.
Pressure Size Curve
Pressure Size Curve

Behind the pressure size button there is a button to reveal the size pressure curve panel. When you activate Size Pressure for tablets, then the Size Pressure curve becomes active, and can be adjusted.

The pressure size curve allows you to adjust the falloff curve for the tablet pressure. It shows when Use Pressure is activated. The curve panel shows when clicking at the button.

Selecting Points
Selecting Points

You can select curve points. This reveals two edit boxes for the x and y coordinate of this point.

Selected points can be moved around. Left click at them, hold the mouse button down and move them to a new location.

Adding Points
Adding Points

You can add new curve points by simply left clicking at the curve. Move the mouse to position them where you need it.

Navigation elements
EntryWhat it does
Zoom inZooms in.
Zoom outZooms out.

Clipping options

Clipping options

Set up clipping for the stroke.

Tools

Tools

Tools is a menu where you can find some curve related tools.

EntryWhat it does
Reset ViewResets the curve windows zoom.
Reset CurveResets the curve to the initial shape.

Handles

Handles

You can choose between Auto handle, Vector Handle and Auto Clamped.

EntryWhat it does
Position X / YThe position of the selectedc curve point.
Delete PointsDeletes the selected curve point.

Curve Presets

Curve Presets

A curve preset to start with.

Value Jitter

Randomize original value. Modifies the brightness of the stroke. You need to be in color attribute mode.

EntryWhat it does
Stroke RandomizationUse randomness per stroke, instead of while drawing a stroke. This will define a new random value when you draw a new stroke.
Use PressureUses the brush pressure to define how random the influence will be. Maximum pressure is maximum randomization.
Pressure Size Curve
Pressure Size Curve

Behind the pressure size button there is a button to reveal the size pressure curve panel. When you activate Size Pressure for tablets, then the Size Pressure curve becomes active, and can be adjusted.

The pressure size curve allows you to adjust the falloff curve for the tablet pressure. It shows when Use Pressure is activated. The curve panel shows when clicking at the button.

Selecting Points
Selecting Points

You can select curve points. This reveals two edit boxes for the x and y coordinate of this point.

Selected points can be moved around. Left click at them, hold the mouse button down and move them to a new location.

Adding Points
Adding Points

You can add new curve points by simply left clicking at the curve. Move the mouse to position them where you need it.

Navigation elements
EntryWhat it does
Zoom inZooms in.
Zoom outZooms out.

Clipping options

Clipping options

Set up clipping for the stroke.

Tools

Tools

Tools is a menu where you can find some curve related tools.

EntryWhat it does
Reset ViewResets the curve windows zoom.
Reset CurveResets the curve to the initial shape.

Handles

Handles

You can choose between Auto handle, Vector Handle and Auto Clamped.

EntryWhat it does
Position X / YThe position of the selectedc curve point.
Delete PointsDeletes the selected curve point.

Curve Presets

Curve Presets

A curve preset to start with.

Jitter

Add Jitter.

Use Pressure

The button behind the edit box enables tablet pressure sensitivity.

Pressure Size Curve
Pressure Size Curve

Behind the pressure size button there is a button to reveal the size pressure curve panel. When you activate Size Pressure for tablets, then the Size Pressure curve becomes active, and can be adjusted.

The pressure size curve allows you to adjust the falloff curve for the tablet pressure. It shows when Use Pressure is activated. The curve panel shows when clicking at the button.

Selecting Points
Selecting Points

You can select curve points. This reveals two edit boxes for the x and y coordinate of this point.

Selected points can be moved around. Left click at them, hold the mouse button down and move them to a new location.

Adding Points
Adding Points

You can add new curve points by simply left clicking at the curve. Move the mouse to position them where you need it.

Navigation elements
EntryWhat it does
Zoom inZooms in.
Zoom outZooms out.

Clipping options

Clipping options

Set up clipping for the stroke.

Tools

Tools

Tools is a menu where you can find some curve related tools.

EntryWhat it does
Reset ViewResets the curve windows zoom.
Reset CurveResets the curve to the initial shape.

Handles

Handles

You can choose between Auto handle, Vector Handle and Auto Clamped.

EntryWhat it does
Position X / YThe position of the selectedc curve point.
Delete PointsDeletes the selected curve point.

Curve Presets

Curve Presets

A curve preset to start with.

Stabilize Stroke subpanel

Stabilize Stroke subpanel

Draw lines with a delay to allow smooth strokes.

EntryWhat it does
RadiusThe minimum distance from last point before the stroke continues.
FactorSmooth stroke factor. Higher values gives smoother stroke.

Brush Settings Panel - Erase

Brush Settings Panel - Erase
Brush Settings Panel - Erase

Eraser hard, Eraser Point, Eraser Soft, Eraser Stroke

Brush Settings Panel - Erase
Brush Settings Panel - Erase

Size

The Radius edit box allows you to adjust the radius of the brush.

Use Pressure

The button behind the edit box enables tablet pressure sensitivity for radius.

Pressure Size Curve
Pressure Size Curve

Behind the pressure size button there is a button to reveal the size pressure curve panel. When you activate Size Pressure for tablets, then the Size Pressure curve becomes active, and can be adjusted.

The pressure size curve allows you to adjust the falloff curve for the tablet pressure. It shows when Use Pressure is activated. The curve panel shows when clicking at the button.

Selecting Points
Selecting Points

You can select curve points. This reveals two edit boxes for the x and y coordinate of this point.

Selected points can be moved around. Left click at them, hold the mouse button down and move them to a new location.

Adding Points
Adding Points

You can add new curve points by simply left clicking at the curve. Move the mouse to position them where you need it.

Navigation elements
EntryWhat it does
Zoom inZooms in.
Zoom outZooms out.

Clipping options

Clipping options

Set up clipping for the stroke.

Tools

Tools

Tools is a menu where you can find some curve related tools.

EntryWhat it does
Reset ViewResets the curve windows zoom.
Reset CurveResets the curve to the initial shape.

Handles

Handles

You can choose between Auto handle, Vector Handle and Auto Clamped.

EntryWhat it does
Position X / YThe position of the selectedc curve point.
Delete PointsDeletes the selected curve point.

Curve Presets

Curve Presets

A curve preset to start with.

Strength

The Strength edit box allows you to adjust the strength of the brush.

Use Pressure

The button behind the edit box enables tablet pressure sensitivity for strength.

Pressure Size Curve
Pressure Size Curve

Behind the pressure size button there is a button to reveal the size pressure curve panel. When you activate Size Pressure for tablets, then the Size Pressure curve becomes active, and can be adjusted.

The pressure size curve allows you to adjust the falloff curve for the tablet pressure. It shows when Use Pressure is activated. The curve panel shows when clicking at the button.

Selecting Points
Selecting Points

You can select curve points. This reveals two edit boxes for the x and y coordinate of this point.

Selected points can be moved around. Left click at them, hold the mouse button down and move them to a new location.

Adding Points
Adding Points

You can add new curve points by simply left clicking at the curve. Move the mouse to position them where you need it.

Navigation elements
EntryWhat it does
Zoom inZooms in.
Zoom outZooms out.

Clipping options

Clipping options

Set up clipping for the stroke.

Tools

Tools

Tools is a menu where you can find some curve related tools.

EntryWhat it does
Reset ViewResets the curve windows zoom.
Reset CurveResets the curve to the initial shape.

Handles

Handles

You can choose between Auto handle, Vector Handle and Auto Clamped.

EntryWhat it does
Position X / YThe position of the selectedc curve point.
Delete PointsDeletes the selected curve point.

Curve Presets

Curve Presets

A curve preset to start with.

EntryWhat it does
Keep CapsKeep the caps as they are. Do not flatten them.
Active LayerOnly edit the active layer of the object.

Brush Settings Panel - Fill

Brush Settings Panel - Fill
Brush Settings Panel - Fill
Brush Settings Panel - Fill
Brush Settings Panel - Fill
Brush Settings Panel - Fill
Brush Settings Panel - Fill

Note that the Fill tool does not fill an existing stroke like you would expect. It extends existing strokes with closed areas, or the border.

EntryWhat it does
DirectionThe fill direction. Fill Normal or Inverted.
PrecisionFactor for fill boundary accuracy. Higher values are more accurate but slower.
Leak SizeSize in pixels to consider the leak closed.
ThicknessThe thickness of the new created stroke drawn with the fill tool around existing strokes or the border.

Brush Settings Panel - Fill - Advanced Sub panel

Brush Settings Panel - Fill - Advanced Sub panel
Brush Settings Panel - Fill - Advanced Sub panel
Brush Settings Panel - Fill - Advanced Sub panel
Brush Settings Panel - Fill - Advanced Sub panel

Boundary

Boundary

The mode to draw the boundary lines.

Layers

Layers

What layers to use as boundaries.

EntryWhat it does
SimplifyNumber of simplify steps. Large values reduces Fill accuracy.
Ignore TransparencyShow transparent lines to use as boundary for filling.
Limit to ViewportThreshold to consider a color as transparent for filling.
Auto-Remove Fill GuidesAutomatically remove fill guide strokes after filling.

Gap closure sub panel

Gap closure sub panel
Gap closure sub panel
Size

Strokes end extension for closing gaps. A value of zero disables the feature.

Mode
Mode
EntryWhat it does
ExtendExtend strokes in straight lines.
RadiusConnect endpoints that are close together.
EntryWhat it does
Visual AidsShow help lines for stroke extension.
Stroke CollisionCheck if extend lines collides with the strokes.

Color Panel

Color Panel

The default grease pencil color is based at materials. And then this panel is greyed out and dysfunctional. But you can also choose to work with vertex colors instead. And then all the color panel features becomes activated.

Material / Vertex Color

Choose if you want to work with material based colors or with vertex colors. Turn it to vertex colors to activate the features.

Material / Vertex Color
Material / Vertex Color

This can also be done in the tool settings in the header.

Color picker

Define the color for your brush.

EntryWhat it does
Active colorThe active color is the left one. When you click the button with the two arrows down right then you can swap the color with the secondary color. Then this secondary color becomes the primary color, and is active. A click at one of the color fields will open a more detailed color dialog, to Set up the color by using rgb, hsv and hex colors and with value sliders.
Brush colors flipFlips the primary color with the secondary color.

Mode

Mode

How the vertex color is applied.

Mix Factor

Factor used to mix the vertex color to get final color.

Color Panel - Palette sub panel

Color Panel - Palette sub panel
Color Panel - Palette sub panel

Here you will find a predefined color palette, and here you can create a color palette for later reuse.

The color palette cannot be saved externally. It is part of the current blend file. You can however append color palettes from other blend files.

The currently active color is the one with the triangle at it.

The elements are explained from left to right and from top to bottom.

Palette browser

Palette browser

The button at the left opens a drop down list to choose between your palettes.

EntryWhat it does
Edit BoxRead the name of the currently active palette. You can also rename the palette here. A click into the edit box makes the name editable.
Number of usersSee how many users the palette currently has.
Fake UserFake User sets the element to have a fake user. Zero user data-blocks are normally not saved. But sometimes you want to force the data to be kept even when the data block has no user.
Add paletteAdd a new palette.
Remove PaletteClicking at this button removes the palette. Note that you need to save, close Bforartists and reload the blend file to remove the palette completely.
New Palette colorAdjust a color in the color picker. Then click at the add button to add this color to the palette.
Delete Palette colorSelect the color in the palette, then click at the minus button to remove it.
Move Palette Color up and downWith these two buttons you can move the active color up or down in the palette.

Sort By

Sort By

Sort the palette by different methods.

Palette Colors

Palette Colors

The actual list of the current palette colors. Click at one to make it the active one that gets used for painting.

Layer Panel

Layer Panel

The content of the Tool tab in the sidebar and the tool settings above the 3D view is usually equal. The Layer panel is a special panel in this regards. It just exists in the tool settings above the 3Dview. And it exists in all grease pencil modes but the object mode.

Grease Pencil objects each have a list of 2D layers for grouping and arranging strokes in a List view. Any stroke can only belong to a single 2D layer. There is always only one active layer in the list (the selected one). When you draw, the new strokes are added to the active layer. By default the view order of the layers in the viewport is top to bottom.

Every layer correspond to a channel in the Dope Sheet editor (in Grease Pencil mode). Layers can also be used together with Modifiers to only affects part of your drawing.

The content is the same than in the Properties editor in the Object Data Properties for a grease pencil object.

Layer Panel
Layer Panel

Layer list

Layer name

The name of the layer.

Grease pencil layers right click menu
Grease pencil layers right click menu
Grease pencil layers right click menu

A right click at a group in the list reveals a menu with further options.

When you click at a group layer, then you will reveal further options.

EntryWhat it does
Edit SourceAllows you to edit the source code.
Reset Panel ZoomResets the zoom of the panel to the default value. Note that this entry is dysfunctional. You cannot zoom the panel.
Delete Group
Delete Group

Deletes the selected group. It does not keep the children, and deletes the whole hierarchy.

EntryWhat it does
UngroupUngroups the selected group.
Merge GroupCombine the layers in this group into a single layer.
ColorsAllows you to color your layer groups in the list. It does not show
EntryWhat it does
Mask LayerToggle the Masks visibility in the layer.
Onion SkinningToggle the use the layer for Onion Skinning.
Viewport/Render VisibilityToggle layer visibility in the viewport and in render.
LockToggle layer from being editable.
Search Field
Search Field

You can expand a search field at the bottom of the list. Type in your term and hit enter to filter for your term.

Add new layer

Add new layer

Adds a new layer.

EntryWhat it does
Remove Layer / Layer GroupDeletes the selected layer or layer group. **Note:**If it removed a Layer group, it keeps the children, and the hierarchy.
Add New Layer GroupAdds a group. You can then drag n drop layers into it. The group will be added as a child when you have a group selected.

Add Extra menu

Delete Group
Delete Group

Deletes the selected group. This only shows when you have a group selected.

Ungroup
Ungroup

Ungroups the selected group. This only shows when you have a group selected.

EntryWhat it does
Move To TopMoves the active selected grease pencil layer to top
Move To BottomMoves the active selected grease pencil layer to bottom
Duplicate LayerMakes an exact copy of the selected layer appending a number to differentiate its name. This method does not duplicate empty keyframes.
Duplicate Empty layerMakes an exact copy of the selected layer appending a number to differentiate its name. This method does duplicate empty keyframes.
Show AllTurns on the visibility of every layer in the list.
Hide OthersTurns off the visibility of every layer in the list except the active one.
Lock AllLocks edition of all the layers in the list
Unlock AllUnlocks edition of all the layers in the list.
Merge DownMerge the selected layer with the layer below. The new layer keeps the name of the lower layer.
Merge AllMerge the selected layer with all layers. The new layer keeps the name of the active layer.
Mask with Layer AboveMask the active layer with the layer above.
Mask with Layer BelowMask the active layer with the layer below
Copy Layer to SelectedAppends the active layer to the selected object.
Copy all Layers to SelectedAppends all layers to the selected object.

Reorder Layer

Reorder Layer

Move the selected layer up or down in the list.

EntryWhat it does
Isolate LayersLocks and hides all not active layers.
Isolate layersLocks all not active layers.

Autolock Inactive layers

Autolock Inactive layers

Automatically lock all layers except the active one to avoid accidental changes

Ignore Material Locking

Allow editing strokes even if they use locked materials.

Blend Mode

Blend Mode

The layer blending operation to perform. See Color Blend Modes.

EntryWhat it does
OpacityUsed to set the opacity of the layer.
LightsWhen enabled, the layer is affected by lights.

Context Menus

Brushes context menu

Draw Mode - Brushes Context Menu

Call this menu with double right click in the 3D viewport. You need to be in Draw mode with a grease pencil object.

In Draw mode you will call a context menu with the sliders from the Brush settings.

Draw Mode - Brushes Context Menu
Draw Mode - Brushes Context Menu
EntryWhat it does
RadiusThe radius of the sculpt brush.
StrengthThe strength of the sculpt brush.

Active Layer

The active grease pencil layer. You can choose another layer, and add new layers here too. It is the same content than in the Properties editor.

EntryWhat it does
Layer drop down boxThe list of available layers. · New Layer: Add a new grease pencil layer.
Layer Edit BoxThe currently active grease pencil layer. Rename it by clicking into the field.
Remove LayerRemove the grease pencil layer.

Active Material

Active Material

The current active material.

EntryWhat it does
Material drop down boxThe list of available materials.
Material Edit BoxThe currently active material. Rename it by clicking into the field.