View & accessibility
Thumbnails
Motion
Bforartists
5.1
Editors

Sidebar

The sidebar tabs and panels of All Modes.

24
 min read
Up to date for 
5.1
draft

Introduction

Introduction

The 3D View is made of several areas. At the right side you will find the sidebar.

In the sidebar you will find tool settings and view related settings. And it is also the home of addons. The Create tab is already created by an add-on. The Mini Lightlib add-on., which is covered in chapter 7.3.13

The content differs, dependent of the chosen object and the current mode.

The Tools tab is also a special chapter. It contains the settings for the tools from the tool shelf.

Animation Tab

Animation tab - Global Transform Panel

Animation tab - Global Transform Panel
Animation tab - Global Transform Panel

Tools that can be useful for animation. Paste a mirrored armature part for example.

EntryWhat it does
CopyCopies the matrix of the current active object or bone to the clipboard. It uses world space matrices.
PastePastes the copied matrix to the current active object or bone from the clipboard. It uses world space matrices.
MirroredPastes the copied matrix to the current active object or bone from the clipboard. But mirrored along the global X axis. It uses world space matrices.

Paste to selected keys

Paste to selected keys
Paste to selected keys
Paste to selected keys
Paste to selected keys

Requires Auto Keying to be on.

Pastes the matrix from the clipboard to thecurrent active object or bone. It uses world space matrices.

Paste and Bake

Requires Auto Keying to be on.

Pastes the matrix from the clipboard to thecurrent active object or bone. And bakes it ton an action. It uses world space matrices.

Mirror Subpanel

Mirror Subpanel
EntryWhat it does
ObjectThe object to mirror over. Leave empty and name a bone to always mirror over that bone of the active armature.
BoneBone to use for the mirroring.

Relative Subpanel

Relative Subpanel

The upper global transform copy and paste actions works global. These buttons works relative to a chosen object.

EntryWhat it does
ObjectThe object to paste relative to its matrix.
CopyCopies the matrix of the current active object or bone to the clipboard. It uses the relative matrix from the defined object.
PastePastes the copied matrix to the current active object or bone from the clipboard. It uses the relative matrix from the defined object.

Fix to Camera subpanel

Fix Location / Rotation / Scale

Include location /rotation /scale keys when fixing to the scene camera.

Fix to Scene Camera

Fix to Scene Camera
Fix to Scene Camera

The actual fixing. Generate new keys to fix the selected object / bone to the camera on unkeyed frames.

Adjust last operator Fix to Scene Camera
Location / Rotation / Scale
Location / Rotation / Scale
Location / Rotation / Scale

Include location /rotation /scale keys when fixing to the scene camera.

Delete generated keys

Delete the keys that were generated by the Fix to Scene Camera tool.

Item tab

Item tab - Transform Panel

Item tab - Transform Panel
Item tab - Transform Panel

When you add an object to the scene then the Item tab with the Transform panel becomes visible. The content changes, dependent of the object type. And it changes with the mode.

In general you will most of the time see the same content though. Location, Rotation, Scale and Dimension.

Animate Property

The properties with a dot button behind can be animated.

Note that you can, different from Blender, animate multiple objects at once this way.

Keyframe and Driver coloring

Keyframe and Driver coloring
Keyframe and Driver coloring

When a keyframe exists at the current position, then the corresponding edit box turns yellow. When a driver exists at the current position, then the corresponding edit box turns purple.

Note that you can have either a driver or a keyframe. Both is not possible.

Location

The current location of the object in its X, X and Z axis. The lock button behind the edit boxes allows you to lock the values.

Rotation

Rotation

The current rotation of the object in its X, X and Z axis in world coordinates. The lock button behind the edit boxes allows you to lock the values.

Rotation Mode

Adjust what method gets used for the rotation. Euler rotation can run into a so called Gimbal lock, which can be avoided with quaternion rotation mode. But for most cases the default XYZ Euler method should work.

Quaternion
Quaternion
Quaternion

With euler angles you will have three values available. But with a quaternion you will have four values available. And quaternions reveals a 4L button. This button shows or hides a lock behind the W value. Normally a quaternion has just three locks, one for each of the single axis. The W value is a mathematical construct from the three object axis. And you usually neither want to edit it nor to lock it therefore.

Locking the W axis will lock all axis.

Scale

The current scale of the object in its X, X and Z axis in world coordinates. The lock button behind the edit boxes allows you to lock the values.

Scale is not dimensions. Your object can have a scale of 1 in world coordinates. But a dimension of 4.5. Note that for some operations it is required to have a scale of 1 to get some operations to work. This can be achieved with applying scale in the Object menu.

Dimensions

The current dimension of the object in its X, X and Z axis in world coordinates. The lock button behind the edit boxes allows you to lock the values.

The Dimensions edit boxes are just available for primitives objects. Objects like Empties or a Camera doesn't have a dimension, but a scale factor.

Right Click menu

Location, Rotation and Scale edit boxes and the locks have a right click menu with further functionality.

When there is already a keyframe available then the right click menu looks a bit different. Same counts for adding a driver first.

Right Click menu
Right Click menu
Right Click menu
EntryWhat it does
Insert KeyframeInserts a keyframe at the current position. The keyframe type depends of where you right click. Insert Keyframe adds a keyframe for all axis.
Insert Single KeyframeInserts a keyframe at the current position. The keyframe type depends of where you right click. Insert Single Keyframe adds a keyframe for just the current axis.

Add Driver

Add Driver

In Bforartists lots of things can be animated. Also buttons. Add Driver does exactly what it tells. It adds a driver for animation needs to the element. Drivers allows to control animation by properties like expressions, scripts or movements of other objects. Drivers are explained in the chapter 18 Editors - Drivers.

When you click the button the Driven Property panel will appear where you can change the properties for this driver. You don't need to confirm the driver creation. It is just further settings.

Driver Settings
EntryWhat it does
TypeThe Driver type. There are two categories of drivers. Built-in and Custom · Built-in functions (Average, Sum, Min and Max): The driven property will have the value of the average, sum, lowest or highest (respectively) of the values of the referenced Driver Variables. If there is only one driver variable, these functions will yield the same result. · Custom (Scripted Expression): An arbitrary Python expression that can refer to the Driver Variables by name.
Driver ValueThe current result of the driver setup.
Expression
EntryWhat it does
Expression edit boxAdd a custom expression. An Expression to use for scripted expression. The expression has access to a set of standard constants and math functions provided in the Driver Name space. For an example of adding a custom function to the name space. When the expression is invalid then you get an error message. This error message appears also with the default values. Just ignore.
Use SelfThe variable self can be used for drivers to reference their own data. This is useful for objects and bones to avoid having creating a Driver Variable pointing to itself. Example: self.location.x applied to the Y rotation property of the same object will make the object tumble when moving. Note that dependencies for properties accessed via self may not be fully tracked.
Driver Variables
Driver Variables

Driver Variables are references to properties, transformation channels, or the result of a comparison between transformations of two objects. It is displayed by a panel with all necessary settings, which gets filled in automatically when you create the driver.

Add Input variable

Add manually a new driver variable.

Picker should allow you to pick a target object. But this is dysfunctional here since the panel closes immediately when you move the mouse out of it. Please use the picker in the Driver Editor.

Copy and Paste buttons allows you to copy and paste Driver variable panels.

Driver Variable panel

Variable type

Variable type

The content of the Driver variable panel changes, dependent of the variable type that you choose here. We came from the transform panel, so our default type here is transform channel. That's what we will explain here.

EntryWhat it does
ObjectOur object type.
TypeThe type of the driver.
SpaceThe transform space in which the transform should happen.
ValueThe resulting value of the driver.
EntryWhat it does
Update DependenciesUpdate all dependencies.
Show in Drivers EditorOpens the Drivers editor in a floating window. The drivers editor is explained in the chapter 18 Editors - Drivers.
Open Drivers Editor
Open Drivers Editor

Opens the Drivers editor in a floating window. The drivers editor is explained in the chapter 18 Editors - Drivers.

EntryWhat it does
Add All to Keying SetAdd All to Keying Set adds the information of the element to the current keyframe.
Add single to Keying SetAdd to Keying Set adds the information of the element to the current keyframe.
Remove from Keying SetRemove from Keying Set removes the information of the element from the current keyframe. · Reset All to Default Value: Resets the X Y and Z values to the default value. · Reset Single to Default Value: Resets the value for the single edit box under the mouse to the default value.
Copy All to SelectedAllows to copy the current rotation of all axis to another object. Workflow. Select target object, hold down shift, select source object, and use Copy All to Selected.
Copy Single to SelectedAllows to copy the current rotation of the single selected axis to another object. Workflow. Select target object, hold down shift, select source object, and use Copy All to Selected.
Copy Data PathCopy Data Path copies the RNA data path for this property.
Copy Full Data PathCopy Data Path copies the RNA data path for this property.
Copy as new DriverCopies the current value as a new driver.
Assign ShortcutThis is just for the locks. Here you could assign a shortcut.
Online Python ReferenceDeveloper feature. Open the Blender Python Reference.
Edit SourceDeveloper feature. When you have a text editor open in the current layout then you can call the UI script that contains this menu item.
Replace KeyframesReplaces the keyframes in all axis at the current position.
Replace single KeyframeReplaces the keyframe in the currently selected axis at the current position.
Delete KeyframesDeletes the keyframes in all axis at the current position.
Delete Single KeyframeDeletes the keyframe in the currently selected axis at the current position.
Clear KeyframesDeletes all keyframes for all axis.
Clear single KeyframeDeletes all keyframes for the currently selected axis.
Delete DriversDeletes the drivers for all axis.
Delete Single DriverDeletes the drivers for just the current axis.
Copy DriverCopies the driver.
Edit DriverOpens the Driven Property panel where you can change the settings for this driver.
Reset Panel ZoomResets the panel to 100% zoom factor.

Item tab - Transform Panel in Edit Mode

Just primitive objects like mesh and curve does have an edit mode. Non primitive objects like a camera or an empty doesn't have an edit mode. With two exceptions. Text and Force Field type Curve Guide. Both are curve types.

Item tab - Transform Panel in Edit Mode
Item tab - Transform Panel in Edit Mode

Mesh Objects

EntryWhat it does
MedianMedian is the position of the selected mesh part.
Global / LocalDefine if the orientation of the selection is local to the selected object, or global to the world coordinates.
Vertices DataMean Bevel Weight: Adjust the bevel weight for the selected vertices when you have a bevel modifier at the mesh.
Edges DataMean Bevel Weight: Adjust the bevel weight for the selected edges when you have a bevel modifier at the mesh. · Mean Crease: Adjust the weight of the selected vertices when you have a subdivision surface modifier at the mesh.

Curve Objects / Surface Objects

Curve Objects / Surface Objects
Curve Objects / Surface Objects
EntryWhat it does
MedianMedian is the position of the selected mesh part
Global / LocalDefine if the orientation of the selection is local to the selected object, or global to the world coordinates.
Mean WeightAdjust the weight used by softbody. Needs softbody.
Mean RadiusAdjust the radius of the curve control points
Mean TiltAdjust the tilt of the curve control points.

Metaball Objects

Median
Median

Median is the position of the selected mesh part

EntryWhat it does
Global / LocalDefine if the orientation of the selection is local to the selected object, or global to the world coordinates.
RadiusAdjust the radius of the selected meta element.
Stiffness
Stiffness

Adjust the stiffness of the selected meta element.

Type

Type is a drop down box. Adjust the meta element type.

Text Objects

Text Objects

Text objects do have an edit mode, but they don't show content in the Transform panel.

Armature objects Edit Mode

Armature objects Edit Mode
Armature objects Edit Mode

Bones do have a head and a tail. You cannot position the whole bone by numeric values, but the head and tail joints.

EntryWhat it does
HeadAdjust the world position of the head joint in x, y and z coordinates. · Radius: This is just useful when you use Envelopes type bones. Adjust the Envelope radius of the head joint.
TailAdjust the world position of the tail joint in x, y and z coordinates. · Radius: This is just useful when you use Envelopes type bones. Adjust the Envelope radius of the tail joint.
RollAdjust the bone roll. · Length: Adjust the length of the bone. · Envelope: This is just useful when you use Envelopes type bones. Adjust the overall Envelope size. · Lock: Lock the transform of the bones in edit mode. The bones cannot be moved, rotated or scaled.

Lattice Objects

Lattice Objects

You need to have some vertices of the Lattice object selected to see the content.

EntryWhat it does
VertexSee and set the vertex positions of the lattice objects.
Global / LocalDefine if the orientation of the selection is local to the selected object, or global to the world coordinates.
Mean WeightLattice object is a deform cage. Adjust the mean weight of the selected vertice(s).

Item tab - Transform Panel in Pose Mode

Item tab - Transform Panel in Pose Mode
Item tab - Transform Panel in Pose Mode

Armature Objects in Pose Mode

The content in Pose mode is the same than in Object mode. We have Location, Rotation and Scale Edit Boxes. And the corresponding lock and animate buttons.

With one small difference. The rotation mode starts with Quaternions by default. And not with Euler Angles.

Item tab - Mesh Object - Vertex Weights Panel

Item tab - Mesh Object - Vertex Weights Panel
Item tab - Mesh Object - Vertex Weights Panel

The Vertex Weights panel shows in Edit and Weight Paint mode, when you have vertices selected, and the selected vertice(s) has a weight assigned.

It allows you to modify the weight of this selected vertice(s).

In Weight paint mode you need to be in vertex selection mode and have a vertice selected. It will not show with face select mode. To select a vertice in weight paint mode hold down ctrl and click.

In Edit Mode you can select more than one vertices. In Weight Paint Mode just one vertice at a time.

EntryWhat it does
Filter Vertex GroupsThe first row is a setting. You can filter by all, only vertex groups that are assinged to deform bones. Or vertex groups that are assigned to non deform bones.
GroupSet as active Vertex Group. · Weight: The weight of the selected vertice(s). The range goes from 0 to 1. · Paste Weight to Selected: Copy this group's weight to other selected vertices. · Delete Weight: Deletes the weight for this selected vertice(s).
NormalizeNormalizes the weight of the selected vertice(s).
CopyCopy active vertex to other selected vertices.

Item tab - Curve Object - Active Spline Panel

Item tab - Curve Object - Active Spline Panel
Item tab - Curve Object - Active Spline Panel
EntryWhat it does
CyclicMake this curve or surface a closed loop in the U direction.
Resolution USubdivisions per segments.

Interpolation Tilt

Interpolation Tilt

The tilt interpolation type.

Radius

Radius

The radius interpolation type.

Smooth

Smooth the normals of the surface or a beveled curve.

Item tab - Surface Object - Active Spline Panel

Item tab - Surface Object - Active Spline Panel
Item tab - Surface Object - Active Spline Panel
EntryWhat it does
Cyclic U / VMake this curve or surface a closed loop in the U or V direction.
Bezier U / VMake this curve or surface act like a Bezier curve in the U or V direction.
Endpoint U / VMake this nurbs or surface meet the endpoints in the U or V direction.
Order U / VNurbs Order in the U or V direction.
Resolution U / VThe subdivision per segment.
SmoothSmooth the normals of the surface or a beveled curve.

Item tab - Grease Pencil Object - Active Spline Panel

Cyclic

Cyclic

Make this curve or surface a closed loop in the U direction.

View Tab

View tab

View tab

The View tab contains viewport related settings.

The content is in all modes and for all object types the same.

View tab - View Panel

View tab - View Panel
View tab - View Panel

The View panel contains some camera settings for the world camera and the render camera.

EntryWhat it does
Focal LengthSet up the focal length for the world camera. You need to be in perspectivic view. In Orthographic view the lens values doesn't have an effect.
Clip Near / Clip FarSet up the clipping values for the world camera. Geometry behind the end value and before the start value will not be drawn.

Use Local Camera

Use Local Camera

Normally when you render an image it gets rendered from the currently active camera. Define a custom camera that is always used for rendering. Regardless which camera is the active one.

Passepartout

Passepartout

Toggles and shows all camera passepartout overlays.

Use Render Region

Use Render Region

When you have defined a render region rectangle, then you can toggle it on and off with this switch. See View menu in the 3d view header, the render region menu item.

Camera Lock

Camera Lock

Camera Lock is a sub tab with camera related settings.

EntryWhat it does
Lock to ObjectLocks the view of the world camera to an object. Choose an object for it.
Lock to 3D CursorLocks the view of the world camera to the 3D cursor. You can either lock to an object or to the 3d cursor. When you choose an object then the checkbox for the 3d cursor vanishes.

Lock Camera to view

Lock Camera to view
Lock Camera to view

This menu item allows you to navigate in camera view like you would be in world view. When it is unticked then you can navigate the passepartout, you can zoom and move it. And when you rotate the view, then you will leave the camera mode.

Lock Camera to view
Lock Camera to view

Note that this functionality also exists in the header when you are in camera view. This double menu entry exists by design.

Lock View Rotation

Locks the camera rotation, you cannot rotate the camera anymore. A use case is the 2D Animation workspace, where you can easily accidentally rotate the orthographic view out of position.

View tab - Edit Panel

View tab - Edit Panel
View tab - Edit Panel

Lock Object Modes

Restrict selection to content that is in the same mode than the current element.

View Tab - 3D Cursor Panel

Location

Location

The position of the 3D cursor in world coordinates.

Rotation

The rotation of the 3D cursor in world coordinates.

Right Click menu

Right Click menu

When you right click at the edit boxes then a menu with further functionality appears.

EntryWhat it does
Reset All to Default ValueResets the X Y and Z values to the default value.
Reset Single to Default ValueResets the value for the single edit box under the mouse to the default value.
EntryWhat it does
Copy All to SelectedAllows to copy the current rotation of all axis to another object. Workflow. Select target object, hold down shift, select source object, and use Copy All to Selected.
Copy Single to SelectedAllows to copy the current rotation of the single selected axis to another object. Workflow. Select target object, hold down shift, select source object, and use Copy All to Selected.
Copy Data PathCopy Data Path copies the RNA data path for this property.
Copy as new DriverCopies the current value as a new driver.
Online Python ReferenceDeveloper feature. Open the Blender Python Reference.
Edit SourceDeveloper feature. When you have a text editor open in the current layout then you can call the UI script that contains this menu item.
Reset Panel ZoomResets the zoom level of the sidebar. You can zoom it with holding Ctrl and dragging MMB.

View tab - Collections Panel

Local Collections

Local Collections

Allows the list of visible collections to be controlled per viewport rather than globally.

List of Collections

The Collections panel shows a list of collections. They can be hidden in the viewport by clicking on the eye icon.

If a collection contains objects, there is a circle to the left of the collection name. If a collection is empty, there is no circle to the left of the collection name.

By clicking directly on the collection names, it “isolates” the collection by hiding all other collections, and showing the direct parents and all the children of the selected collection.

View tab - Annotations Panel

View tab - Annotations Panel
View tab - Annotations Panel
View tab - Annotations Panel
View tab - Annotations Panel

Manage the Annotation layers and materials.

When you don't have drawn an annotation yet then the panel just contains a New button.

Annotations prop

Annotations prop

Add, remove and rename new annotations.

Drop down box

A list of the available annotation layers.

EntryWhat it does
Edit BoxThe name of the current annotation. You can rename the annotation to your needs here.
Fake UserAssign a fake user to this annotation. Fake users is an odd concept to keep data in the scene even if it has no user somewhere. The fake user is then a dummy user so that the object is not deleted when saving the scene.

List of Annotation Strokes

List of Annotation Strokes
List of Annotation Strokes

Here you see your Annotation layers for the current Annotation. Every layer can have an own color.

At the right side you find buttons to sort them and to add and remove new Annotation layers.

You can change the color by clicking at the color field. A color dialog will pop up. You can rename annotation layers by double clicking at it.

EntryWhat it does
In FrontToggle if the stroke is displayed in front of geometry or behind.
Eye iconThe eye icon allows you to make it invisible And it has a search field.
Add AnnotationAdd a new annotation.
Delete AnnotationDelete the annotation.
Move up / DownMove the selected annotation up or down in the list
EntryWhat it does
OpacityThe opacity of the stroke.
ThicknessThe thickness of the annotation stroke.
Frame Locked/UnlockedLock frame displayed by current layer. This toggles whether the active layer is the only one that can be edited.

Onion Skin

Onion Skin

Enable Onion Skinning.

Onion Skinning allows to show ghosts of the keyframes before and after the current frame. In this sub panel you can adjust the color of the onion skin frames.

With the numbers below the colors you can define how many frames before or after are displayed that way.

View tab - Stereoscopy Panel

View tab - Stereoscopy Panel
View tab - Stereoscopy Panel

This panel shows when you have Stereoscopy enabled in the Output Properties of the Properties editor. Some content depends of the Stereoscopy settings.

View tab - Stereoscopy Panel
View tab - Stereoscopy Panel

Left / Right / 3D

Left / Right / 3D
Left / Right / 3D

With Stereoscopy setting Stereo 3D.

Show the image in the 3d view from the left or right camera, or from both.

Views / 3D

Views / 3D

With Stereoscopy setting Multi-View.

Show the image in the 3d view from the single cameras, or from both.

EntryWhat it does
CamerasWith Stereoscopy setting Stereo 3D. Show the left and right cameras.
PlaneShow the convergence plane. · Alpha: The transparency of the convergence plane.
VolumeShow the stereoscopy volume. · Alpha: The transparency of the stereoscopy volume.

Set Stereo 3D

Set Stereo 3D

Calls a panel where you can adjust the stereoscopy display in the 3D view to preview the result.

This settings does not affect the output, just how the result gets displayed in the viewport!

Display Mode

Display Mode

How to display the stereoscopic image when viewing through the camera. This is the preview mode. You need a special monitor for some of the methods. There are five methods available.

Display Mode Type Anaglyph

Display Mode Type Anaglyph
Display Mode Type Anaglyph

Render Views for left and right eyes as two differently filtered colors in a single image. You need anaglyph glasses to see the 3d effect.

Display Mode Type Anaglyph
Display Mode Type Anaglyph
Anaglyph Type
Anaglyph Type

The color model to display the graphics.

Display Mode Type Interlace

Display Mode Type Interlace
Display Mode Type Interlace

Render Views from left and right eyes interlaced into a single image. You need a 3D Ready monitor to see the stereo effect.

Display Mode Type Interlace
Display Mode Type Interlace
Interlace Type
Interlace Type

The interlace type that you can choose.

Swap Left/Right

Swaps left and right camera view.

Display Mode Type Time Sequential

Display Mode Type Time Sequential
Display Mode Type Time Sequential

Render alternate eyes. Also known as page flip. Needs a graphics card that supports quad buffer.

Display Mode Type Side by Side

Display Mode Type Side by Side
Display Mode Type Side by Side

Displays images of the two cameras side by side. You need to go into Window Full screen to see the effect.

Display Mode Type Side by Side
Display Mode Type Side by Side

Don't use the full screen. feature in the View menu of the 3D view, but the Window toggle full screen. in the Window menu!

Warning: the menus becomes nearly unreadable then. The whole UI gets distorted by splitting the main window of Bforartists into two views. You might want to assign a shortcut here before trying.

Cross Eyed
Cross Eyed

Swaps left and right camera view.

Display Mode Type Top Bottom

Display Mode Type Top Bottom
Display Mode Type Top Bottom

Displays images of the two cameras top and bottom. You need to go into Window Full screen to see the effect.

Display Mode Type Top Bottom
Display Mode Type Top Bottom

Don't use the full screen. feature in the View menu of the 3D view, but the Window toggle full screen. in the Window menu!

Warning: the menus becomes nearly unreadable then. The whole UI gets distorted by splitting the main window of Bforartists into two views. You might want to assign a shortcut here before trying.

Display Mode Type Top Bottom
Display Mode Type Top Bottom

View tab - Quad View panel

View tab - Quad View panel
View tab - Quad View panel

This panel just shows when you are in quad view. Toggle Quad View can be found in the View menu.

Lock rotation

Quad view has four windows. Three of them can be locked to the orthographic views.

Lock rotation

Turning off Lock Rotation reveals the quick navigation buttons Switch to Camera View and Switch between Perspectivic and Orthographic display.

EntryWhat it does
Sync Zoom PanIn the three orthographic views you can either zoom and pan individually. Or you zoom and pan them in sync.
Clip ContentsClip objects based on what is visible in the other orthographic side views. The perspectivic view is not affected.

View tab - Important Hotkeys

View tab - Important Hotkeys
View tab - Important Hotkeys

This panel is an addon called Important Hotkeys, and can be turned off in the Preferences.

It displays the most important hotkeys in the viewport.

EntryWhat it does
Show TextShow or hide the text in the viewport.
ColorDefine what color the text should have. Default is white.

Font Size

The size of the font.

Font Size