View & accessibility
Thumbnails
Motion
Bforartists
5.1
Editors

Timeline header

The header contains various menus and tools. This chapter here is about the tools and options elements in the header.

12
 min read
Up to date for 
5.1
draft

Introduction

The header contains various menus and tools. This chapter here is about the tools and options elements in the header.

The text menus are covered in its own chapter each.

Introduction

Playback Elements

Playback Elements

The playback elements allows you to play your animation, and set the animation range.

Time Jump Delta

Time Jump Delta

Number of frames or seconds to jump forward or backward.

Jump Unit

What to use for the time jump. Frames or Seconds.

PropertyWhat it changes
Jump to Endpoint - startJumps to the first frame.
Jump to Keyframe - previousJumps to the keyframe before the current position.
Play Animation - backwardPlays the animation in reverse direction.
Play Animation - forwardPlays the animation.
Jump to Keyframe - nextJumps to the keyframe after the current position.
Jump to Endpoint - endJumps to the last frame.
Cancel animationCancels the animation and returns to the original frame.
Current FrameThe edit box with the position of the current frame. Click at the value and type in another value to jump to another frame.

Set Start Frame

Set Start Frame

Sets the current frame position as the start frame.

Use Preview Range

Use Preview Range

Toggle an alternative range used to preview animations. The Preview range works for the UI playback, but will not work for rendering an animation.

The preview range is displayed in orange color. The original playback range that is used for rendering is still displayed in grey underneath. When Use Preview Range is on, then the animation will loop between the Preview range.

PropertyWhat it changes
StartThe start frame for the animation in current mode.
EndThe end frame for the animation in current mode.
Set End FrameSets the current frame position as the end frame.
Insert KeyframeInserts a keyframe. If you do not have a keying set assigned, this will default to the default keying set defined in the Preferences.
Delete KeyframeRemoves the keyframe at the current position in the current active keying set.

Active Keying Set

Active Keying Set

Objects needs a so called keying set so that you can record animation for it. It is a container for the animation, a set of keyframe channels. When you try to record an animation without an existing keying set, then you will get a warning since the channels for the keyframes are missing.

In this property you can choose a method from the builtin keying sets.

Auto Keying

With auto keying on every manipulation in the 3d view will automatically create a keyframe, or update the existing keyframe at the current position.

Note that Auto Keying just works with transform properties ( Objects and Bones) in the 3d View. It will not work to animate colors in the Properties Editor for example.

Auto Keyframing Popover

Auto Keyframing Popover

Auto keying settings. These settings shows when you have auto keying activated.

PropertyWhat it changes
Auto keying modeAdd & Replace: Replace existing keyframes and add new ones where no keyframes exists. · Replace: Just replace existing keyframes.
Only Active Keying SetAutomatic keyframe insertion using active keying set only.
Layered RecordingAdd a new nla track and strip for every loop or pass made over the animation. This allows non destructive tweaking.
Cycle aware keyingFor channels with cyclic extrapolation, the keyframe insertion is automatically remapped inside the cycle time range, and keeps the ends in sync.

Active Keying Set

Active Keying Set

Choose your keying set.

Playback Panel

Playback Panel

Here you can find various options for playback.

Sync Mode

How to synchronize playback.

PropertyWhat it changes
No SyncDon't synchronize. Play every frame.
Frame DroppingDrop frames if playback is too slow.
AV SyncDrop frames to synchronize to Audio Playback.

Audio Scrubbing

Audio Scrubbing

Play existing audio from sequence editor when scrubbing.

PropertyWhat it changes
Play AudioPlay back existing audio from sequence editor, otherwise mute the audio when deactivated. Use the Sequence Editor to add audio.
Sub framesShow current scene sub frame and allow to set it by using interface tools.
Limit Playback to Frame RangeDon't allow frame selection with the mouse outside of the play range.
Follow Current FrameFollow current frame in editors.

Play in

Play in

Plays the animation in the chosen editor types.

  • Active Editor
  • 3D Viewport
  • Animation Editors
  • Image Editor
  • Properties Editor and Sidebars
  • Movie Clip Editor
  • Node Editors
  • Video Sequencer
  • Spreadsheet

Playhead Snapping

Playhead Snapping

Playhead controls in animation editors help position the current frame indicator with precision, improving navigation and editing across the Timeline, Dope Sheet, Graph Editor, NLA, and Video Sequencer.

PropertyWhat it changes
Toggle Playhead Snapping On/OffToggles snapping behavior for the playhead with a visual indicator. When enabled, the playhead will snap to nearby time-based targets during scrubbing or dragging. Tip: You can temporarily enable/disable the playhead snapping by holding down Ctrl while dragging the playhead.
DistanceSets the snapping threshold in pixels. Determines how close the playhead must be to a target for snapping to occur.
Snap TargetFrames: Snaps to whole frame numbers. Ideal for frame-accurate editing instead of sub-frame cursor placement. · Seconds: Snaps to time intervals measured in seconds. Useful for audio syncing or time-based pacing. · Markers: Snaps to the closest timeline marker. Great for aligning actions to scene events or beats. · Keyframes: Snaps to keyframe positions. Ensures precise alignment for editing and playback. · Strips: Snaps to the start or end of video/audio strips. Useful in the Video Sequencer and NLA editor.

Frame Step

Frame Step

Defines the step size for frame-by-frame navigation. Controls how far the playhead moves when stepping through frames manually.

Note: Only available with Frames Snap Target

Second Step

Defines the step size for second-by-second navigation. Controls how far the playhead moves when stepping through the timeline manually.

Note: Only available with Second Snap Target

Keying Panel

Keying Panel

Some more keying options.

New Keyframe Type

New Keyframe Type

Recolor the currently selected keyframes. Or create the new keyframes with this chosen keyframe color.

Auto Keyframing

Auto Keyframing
PropertyWhat it changes
Auto Keying ModeJust replace existing keyframes, or add keyframes too.
Auto Keyframe Insert Keying SetAutomatic Keyframe Insertion using the active keying set only.
PropertyWhat it changes
Layered RecordingAdd a new NLA Track and Strip for every loop/ pass made over the animation to allow non destructive tweaking.
Cycle Aware KeyingFor channels with cyclic extrapolation, keyframe insertion is automatically remapped inside the cycle time range, and keeps the ends in sync.

Options

Options
PropertyWhat it changes
Only show errorsOnly include f-curves that are disabled or have errors.
Only show selectedJust show the keyframes from the selected object.

Show Seconds

Show Seconds

Show the timing in the timeline area in seconds instead of frames.

PropertyWhat it changes
Sync visible rangeSynchronize the visible timeline range with other visible time based editors. When you zoom in or out in the one editor, then it zooms in or out in the other editor too. Each editor to sync needs to have Sync Visible Range ticked.
Show MarkersDisplay the markers row at the bottom of the view.
Lock MarkersMake the markers uneditable.
Show CacheShow animation information for cached objects like Particles. · Softbody, Particles, etc.: Include or exclude what kind of cache types you want to display.

Dope Sheet Overlays

Show Overlays

Shows the Dope Sheet Overlays.

Overlays

Overlays

Show Scene Strip Range

When using Scene Time Synchronisation in the video sequence editor, then display the range of the current scene strip.

Quick menu

Shared section · Quick menu

Quick menu

The quick menu, or in long Quick Favorites menu, is a menu that can be customized to your needs. Here you can add operators for quick access.

It is located in the header. But it can be called by hotkey Q directly under the mouse. This hotkey works in other editors too.

When the menu is empty, then you will see the message "No Menu Items found". This means that you first have to add some tools to the menu. It is a user configurable menu.

Note that added operators in this menu does not have icons. Just text.

Adding an operator to the Quick menu

Adding an operator to the Quick menu
Adding an operator to the Quick menu

Open the panel or the menu where your operator is that you want to add.

Let's add the open command from the File menu. Open the File menu, right click at open, and choose Add to Quick Favorites.

Do the same with Save As. We should now have two new menu items in the Quick menu, which you can use now.

Adding an operator to the Quick menu
Adding an operator to the Quick menu

As a rule of thumb, when the right click menu has an Add to Quick Favorites, then you can add it to the quick menu.

Note that you can also add operators from the tool shelf at the left. And also operators from other editor types. Some other editors have their own quick menu though. The Image Editor for example. These operators gets added in the quick menu of the image editor then. And does not show in the quick menu in the header of the 3D view.

Adding a menu to the Quick menu

Adding a menu to the Quick menu
Adding a menu to the Quick menu

It is also possible to add a menu to the Quick menu. For example the whole Add menu. The way is the same. Right click at it, and choose Add to Quick Favorites.

Adding a menu to the Quick menu
Adding a menu to the Quick menu

Order

You might notice that the add menu adds at the top of the menu, and not at the bottom as you would expect. First comes menus, then comes operators. And they get added in the order in which you add them.

Besides that, operators and menus gets added in the order that you add them. They cannot be sorted afterwards. So be careful how you add them. You can of course always remove operators and menus, and re-add them at the end of the list.

Removing an operator from the Quick menu

Removing an operator from the Quick menu
Removing an operator from the Quick menu

Removing is as simple as adding. Right click at the operators in the Quick menu, and choose Remove from Quick favorites.

Context and mode dependent content

The quick favorites. menu exists in nearly all editors. But it is just in the 3D view available in the header. So that you know this functionality exists. In the other editors you call it with hotkey Q.

The content of the quick favorites. menu changes, dependent over which editor you are, and in what mode you are. When you add for example an operator from the image editor, then this operator just shows in the quick menu when you call the menu from the image editor. Same goes for the modes. Edit mode tools will just show in edit mode. And so on.

View Menu

View Menu

The View menu contains all View related tools.

Adjust Last Operation

Adjust Last Operation

Shows the adjust last operation panel down left.

Channels

Channels

Shows the channels list at the left

Menu entryWhat it does
Zoom InZooms in.
Zoom OutZooms out.
Zoom BorderDraw a rectangle to zoom to the selection.
Frame AllZooms in or out in the viewport until all objects in the scene are displayed fitting in the viewport.
Go to current FrameCenters the view at the frame slider.
Frame Scene RangeWith Use Preview Range off , reset the horizontal view to the current scene frame range.
Frame Preview RangeWith Use Preview Range on , reset the horizontal view to the current preview frame range.

Area submenu

Area submenu

This menu contains general view functionality. And exists in most other editor types too.

Menu entryWhat it does
Horizontal SplitSplits the current view horizontally into two independent editor windows.
Vertical SplitSplits the current view vertically into two independent editor windows.

Duplicate Area into New Window

Duplicate Area into New Window
Duplicate Area into New Window

Duplicate Area into New Window makes the selected editor window floating. You can then drag it around at the monitor. It is not connected with the rest of the UI anymore.

A separated window cannot be merged into the main window again. You have to close it when not longer needed.

Menu entryWhat it does
Toggle Maximize AreaDisplays the editor maximized with menus. To return from the maximized view press hotkey Ctrl + Space. Or reuse the menu item in the area menu.
Toggle Full screen AreaDisplays the editor maximized without menus. To return from the full screen view press hotkey Ctrl + Alt + Space.
Close AreaCloses the area window.

Marker menu

Shared section · Marker menu

Marker menu

Markers are visual landmarks. They can mark a start of a specific animation sequence, the end of a camera movement, and so on.

When you add one then a marker area appears at the bottom of the timeline.

Markers can be pulled around by clicking at them and dragging them left or right. The active marker is yellow.

By holding down shift you can select more than one marker.

Add Marker

Adds a marker at the current frame position.

Duplicate Marker

Duplicates the selected marker(s). The duplicate(s) sticks at the mouse until you click to give it the target destination.

Duplicate Marker to Scene

Duplicate Marker to Scene
Duplicate Marker to Scene

A blend file can contain more than one scene. See Scene Properties in the Properties editor. Here you can duplicate markers to other scenes.

Duplicate Marker to Scene
Duplicate Marker to Scene

Delete Marker

Deletes the selected marker(s).

Bind Camera to Markers

Bind Camera to Markers
Bind Camera to Markers

Bind camera to markers turns an object into a camera object. This can be any object in the scene. Not just camera objects.

When the current frame position does not have a marker yet, then it creates a marker at the current frame position.

By binding different objects or cameras at different marker locations you can switch cameras automatically.

The marker with a bind camera attached will show a camera icon.

Rename Marker

Rename Marker

A menu will open up where you can rename the active marker.

Move Marker

Hotkey only functionality! This menu item exists to show the hotkey to move the marker.

Select sub menu

Select sub menu
Menu entryWhat it does
AllSelect all markers.
NoneDeselect all markers.
InvertInverts the current selection.
Before Current FrameSelects the markers before the current frame.
After Current FrameSelects the markers after the current frame.

Jump to Next Marker

Sets the frame position to the next marker.

Jump to Previous Marker

Sets the frame position to the previous marker.